aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-09-26 09:13:28 -0700
committerKhem Raj <raj.khem@gmail.com>2011-09-27 17:40:02 -0700
commit9826cc6fead485177bdf35f8d49d98feb2a318d7 (patch)
tree102c51b2467b2ed86d3ca4545b022a4fae3d2419 /meta-gnome/recipes-gnome
parent1dd63580daf20e9c96433d4b4f5b673baa3be29b (diff)
downloadmeta-openembedded-9826cc6fead485177bdf35f8d49d98feb2a318d7.tar.gz
gdm: Fix build on gnome'less build systems
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm-2.32.2/sysrooted-pkg-config.patch37
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb3
2 files changed, 39 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gdm/gdm-2.32.2/sysrooted-pkg-config.patch b/meta-gnome/recipes-gnome/gdm/gdm-2.32.2/sysrooted-pkg-config.patch
new file mode 100644
index 0000000000..1f9fa2ac2f
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gdm/gdm-2.32.2/sysrooted-pkg-config.patch
@@ -0,0 +1,37 @@
+In cross environment we have to prepend the sysroot to the path found by
+pkgconfig since the path returned from pkgconfig does not have sysroot prefixed
+it ends up using the files from host system. Now usually people have gnome installed
+so the build succeeds but if you dont have gnome installed on build host then
+it wont find the files on host system and packages using gnome-doc-utils wont
+compile.
+
+This should work ok with non sysrooted builds too since in those cases PKG_CONFIG_SYSROOT_DIR
+will be empty
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: gdm-2.32.2/gnome-doc-utils.make
+===================================================================
+--- gdm-2.32.2.orig/gnome-doc-utils.make 2011-05-31 08:06:59.000000000 -0700
++++ gdm-2.32.2/gnome-doc-utils.make 2011-09-25 15:32:39.540992521 -0700
+@@ -133,12 +133,12 @@
+ _xml2po ?= `which xml2po`
+ _xml2po_mode = $(if $(DOC_ID),mallard,docbook)
+
+-_db2html ?= `$(PKG_CONFIG) --variable db2html gnome-doc-utils`
+-_db2omf ?= `$(PKG_CONFIG) --variable db2omf gnome-doc-utils`
+-_malrng ?= `$(PKG_CONFIG) --variable malrng gnome-doc-utils`
+-_chunks ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/chunks.xsl
+-_credits ?= `$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/credits.xsl
+-_ids ?= $(shell $(PKG_CONFIG) --variable xmldir gnome-doc-utils)/gnome/xslt/docbook/utils/ids.xsl
++_db2html ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2html gnome-doc-utils`
++_db2omf ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable db2omf gnome-doc-utils`
++_malrng ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable malrng gnome-doc-utils`
++_chunks ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/chunks.xsl
++_credits ?= ${PKG_CONFIG_SYSROOT_DIR}`$(PKG_CONFIG) --variable xmldir gnome-doc-utils`/gnome/xslt/docbook/utils/credits.xsl
++_ids ?= ${PKG_CONFIG_SYSROOT_DIR}$(shell $(PKG_CONFIG) --variable xmldir gnome-doc-utils)/gnome/xslt/docbook/utils/ids.xsl
+
+ if ENABLE_SK
+ _ENABLE_SK = true
diff --git a/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb b/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb
index 6fcea0d5c6..b1cbf457a8 100644
--- a/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb
+++ b/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb
@@ -4,13 +4,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "xinput gnome-panel tcp-wrappers libcanberra libxklavier grep consolekit libpam gnome-doc-utils gtk+ xrdb"
-PR = "r4"
+PR = "r5"
inherit gnome update-rc.d
SRC_URI += " \
file://cross-xdetection.diff \
file://0001-Remove-user-switch-applet.patch \
+ file://sysrooted-pkg-config.patch \
file://%gconf-tree.xml \
file://gdm \
file://gdm.conf \