aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2013-04-15 21:04:11 +0000
committerEric Bénard <eric@eukrea.com>2013-04-22 22:31:53 +0200
commit47de69536963046de85d382c7f1fe68c228d83b3 (patch)
treee281553d941da137b00ad9c00ec6f9d94d991148 /meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
parent28f567584ef1874b379d9d0e2ed13b8fb7732aab (diff)
downloadmeta-openembedded-47de69536963046de85d382c7f1fe68c228d83b3.tar.gz
goffice: update to version 0.10.1
That's a version requirement for Gnumeric. Note that goffice 0.10.1 requires gtk3. Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'meta-gnome/recipes-support/goffice/goffice_0.10.1.bb')
-rw-r--r--meta-gnome/recipes-support/goffice/goffice_0.10.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb b/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
new file mode 100644
index 0000000000..e567b1f9b3
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
@@ -0,0 +1,47 @@
+DESCRIPTION="Gnome Office Library"
+
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6dc33ff21e1ba1ac1a2a1069d361e29e"
+
+DEPENDS = "libxml-parser-perl-native glib-2.0 gtk+3 pango cairo libgsf libpcre libxml2 libart-lgpl"
+
+inherit gnome pkgconfig perlnative
+
+GNOME_COMPRESS_TYPE = "xz"
+
+SRC_URI[archive.md5sum] = "90fd17c6fe205b779571e00d9b0b4727"
+SRC_URI[archive.sha256sum] = "5c38f4e81e874cc8e89481b080f77c47c72bfd6fe2526f4fc2ef87c17f96cad0"
+
+FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+
+RRECOMMENDS_${PN} = " \
+ goffice-plugin-plot-barcol \
+ goffice-plugin-plot-distrib \
+ goffice-plugin-plot-pie \
+ goffice-plugin-plot-radar \
+ goffice-plugin-plot-surface \
+ goffice-plugin-plot-xy \
+ goffice-plugin-reg-linear \
+ goffice-plugin-reg-logfit \
+ goffice-plugin-smoothing \
+"
+
+FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
+ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ ${base_bindir}/* ${base_sbindir}/* \
+ ${base_libdir}/*${SOLIBS} \
+ ${datadir}/${PN} \
+ ${datadir}/pixmaps ${datadir}/applications \
+ ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+ ${libdir}/bonobo/servers"
+
+FILES_${PN}-locale = "${libdir}/locale"
+
+PACKAGES_DYNAMIC += "^goffice-plugin-.*"
+
+python populate_packages_prepend () {
+ goffice_libdir = d.expand('${libdir}/goffice/${PV}/plugins/')
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+