aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-24 16:45:38 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-24 17:34:02 +0200
commit040daebc80af5bdcad3636604ac55fc6a9ac1e5d (patch)
tree25ad7d2bc87fe2b33bcea1a3a3b5dcc123a45b5e /meta-gnome/recipes-support
parentcbcf7323bf48752fe3ca81d4634d3e626507f2e9 (diff)
downloadmeta-openembedded-040daebc80af5bdcad3636604ac55fc6a9ac1e5d.tar.gz
goffice 0.8.17: import from OE classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-support')
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/c99math.patch12
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/nodolt.patch12
-rw-r--r--meta-gnome/recipes-support/goffice/goffice_0.8.17.bb46
3 files changed, 70 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/goffice/goffice/c99math.patch b/meta-gnome/recipes-support/goffice/goffice/c99math.patch
new file mode 100644
index 0000000000..24e6c31a72
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/c99math.patch
@@ -0,0 +1,12 @@
+Index: goffice-0.7.14/configure.in
+===================================================================
+--- goffice-0.7.14.orig/configure.in 2009-11-14 19:14:37.106109501 +0100
++++ goffice-0.7.14/configure.in 2009-11-14 19:19:40.907333188 +0100
+@@ -66,6 +66,7 @@
+
+ AC_ISC_POSIX
+ AC_PROG_CC
++AC_PROG_CC_C99
+ AC_PROG_YACC
+ AM_PROG_LEX
+ AC_PROG_LN_S
diff --git a/meta-gnome/recipes-support/goffice/goffice/nodolt.patch b/meta-gnome/recipes-support/goffice/goffice/nodolt.patch
new file mode 100644
index 0000000000..ea1777a996
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/nodolt.patch
@@ -0,0 +1,12 @@
+Index: goffice-0.7.14/configure.in
+===================================================================
+--- goffice-0.7.14.orig/configure.in
++++ goffice-0.7.14/configure.in
+@@ -71,7 +71,6 @@ AC_PROG_YACC
+ AM_PROG_LEX
+ AC_PROG_LN_S
+ AM_PROG_LIBTOOL
+-DOLT
+ AC_STDC_HEADERS
+ AC_SYS_LARGEFILE
+
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
new file mode 100644
index 0000000000..9988c41202
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
@@ -0,0 +1,46 @@
+DESCRIPTION="Gnome Office Library"
+
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fa1348b178f4a7322170203c6c36f4c3"
+
+DEPENDS = "libxml-parser-perl-native glib-2.0 gtk+ pango cairo libgsf libpcre libxml2 libart-lgpl"
+
+inherit gnome pkgconfig perlnative
+
+SRC_URI += " file://c99math.patch \
+ file://nodolt.patch "
+
+SRC_URI[archive.md5sum] = "b4c924457163e02daf8a8d2428f51d10"
+SRC_URI[archive.sha256sum] = "dd8caef5fefffbc53938fa619de9f58e7c4dc71a1803de134065d42138a68c06"
+
+FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+
+RRECOMMENDS_${PN} = " \
+ goffice-plugin-plot-barcol \
+ goffice-plugin-plot-distrib \
+ goffice-plugin-plot-pie \
+ goffice-plugin-plot-radar \
+ goffice-plugin-plot-surface \
+ goffice-plugin-plot-xy \
+ goffice-plugin-reg-linear \
+ goffice-plugin-reg-logfit \
+ goffice-plugin-smoothing \
+"
+
+FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
+ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ ${base_bindir}/* ${base_sbindir}/* \
+ ${base_libdir}/*${SOLIBS} \
+ ${datadir}/${PN} \
+ ${datadir}/pixmaps ${datadir}/applications \
+ ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+ ${libdir}/bonobo/servers"
+
+PACKAGES_DYNAMIC = "goffice-plugin-*"
+
+python populate_packages_prepend () {
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+