aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-05-17 09:51:54 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-21 12:45:49 +0200
commit2150f733e1c0d95562b08b49513e3ef1e69d627e (patch)
tree66535285d89d2bbae7d6f77c82b8c54cf369bfc6 /meta-gnome
parentcf4e3bbfe3c4d5fe4de02cad2501c73c3fcc6ac9 (diff)
downloadmeta-openembedded-2150f733e1c0d95562b08b49513e3ef1e69d627e.tar.gz
evince: fix build with gcc 4.8
warning/errror was: tiff2ps.c:1131:4: error: format '%u' expects argument of type 'unsigned int', but argument 3 has type 'tsize_t' [-Werror=format=] chunk_size, tiled_image ? "tiles" : "strips"); ^ cc1: some warnings being treated as errors Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/evince/evince/0001-tiff-fix-compile-warning.patch33
-rw-r--r--meta-gnome/recipes-gnome/evince/evince_2.32.0.bb7
2 files changed, 38 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/evince/evince/0001-tiff-fix-compile-warning.patch b/meta-gnome/recipes-gnome/evince/evince/0001-tiff-fix-compile-warning.patch
new file mode 100644
index 0000000000..ebc8976b3d
--- /dev/null
+++ b/meta-gnome/recipes-gnome/evince/evince/0001-tiff-fix-compile-warning.patch
@@ -0,0 +1,33 @@
+From 00b5e55c90477eeac02bec58f032cb6916a1eb5c Mon Sep 17 00:00:00 2001
+From: Hib Eris <hib@hiberis.nl>
+Date: Mon, 20 Feb 2012 21:36:16 +0100
+Subject: [PATCH] tiff: fix compile warning
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Backport
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ backend/tiff/tiff2ps.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/backend/tiff/tiff2ps.c b/backend/tiff/tiff2ps.c
+index c0dc0bf..fc63c2e 100644
+--- a/backend/tiff/tiff2ps.c
++++ b/backend/tiff/tiff2ps.c
+@@ -1127,8 +1127,8 @@ PS_Lvl2page(TIFF2PSContext* ctx, TIFF* tif, uint32 w, uint32 h)
+ }
+ buf_data = (unsigned char *)_TIFFmalloc(chunk_size);
+ if (!buf_data) {
+- TIFFError(ctx->filename, "Can't alloc %u bytes for %s.",
+- chunk_size, tiled_image ? "tiles" : "strips");
++ TIFFError(ctx->filename, "Can't alloc %u bytes for %s.",
++ (uint) chunk_size, tiled_image ? "tiles" : "strips");
+ return(FALSE);
+ }
+
+--
+1.7.6.5
+
diff --git a/meta-gnome/recipes-gnome/evince/evince_2.32.0.bb b/meta-gnome/recipes-gnome/evince/evince_2.32.0.bb
index f1c35636f3..6197564dc1 100644
--- a/meta-gnome/recipes-gnome/evince/evince_2.32.0.bb
+++ b/meta-gnome/recipes-gnome/evince/evince_2.32.0.bb
@@ -4,11 +4,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=96f2f8d5ee576a2163977938ea36fa7b"
SECTION = "x11/office"
DEPENDS = "gnome-icon-theme gnome-doc-utils-native libgnome-keyring nautilus tiff libxt ghostscript poppler libxml2 gtk+ gconf libglade"
-PR = "r4"
+PR = "r5"
inherit gnome pkgconfig gtk-icon-cache gsettings
-SRC_URI += "file://cross-compile-fix.patch"
+SRC_URI += " \
+ file://cross-compile-fix.patch \
+ file://0001-tiff-fix-compile-warning.patch \
+"
SRC_URI[archive.md5sum] = "ebc3ce6df8dcbf29cb9492f8dd031319"
SRC_URI[archive.sha256sum] = "2a4c91ae38f8b5028cebb91b9da9ddc50ea8ae3f3d429df89ba351da2d787ff7"