aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-04-21 20:08:21 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-04-21 20:08:21 +0200
commit111a652bb6631045720bab2947fd798f95bac176 (patch)
tree7dc90e4e93859141dd61757d99c875bb3c5ab5e4 /meta-gnome
parent5ad41af6c5ff1d721c5458fb46bbb8676f9e56b5 (diff)
downloadmeta-openembedded-111a652bb6631045720bab2947fd798f95bac176.tar.gz
libgtkstylus: import from oe-core rev 0a6f77f549c095692045825f4b5c4c5a2edff73c
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/libgtkstylus/files/gtkstylus.sh5
-rw-r--r--meta-gnome/recipes-gnome/libgtkstylus/libgtkstylus_0.5.bb24
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/libgtkstylus/files/gtkstylus.sh b/meta-gnome/recipes-gnome/libgtkstylus/files/gtkstylus.sh
new file mode 100644
index 0000000000..b1302ede0e
--- /dev/null
+++ b/meta-gnome/recipes-gnome/libgtkstylus/files/gtkstylus.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+GTK_MODULES=libgtkstylus.so
+
+export GTK_MODULES
diff --git a/meta-gnome/recipes-gnome/libgtkstylus/libgtkstylus_0.5.bb b/meta-gnome/recipes-gnome/libgtkstylus/libgtkstylus_0.5.bb
new file mode 100644
index 0000000000..f614048a16
--- /dev/null
+++ b/meta-gnome/recipes-gnome/libgtkstylus/libgtkstylus_0.5.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "GTK plugin for stylus based systems"
+SECTION = "libs"
+DEPENDS = "gtk+"
+LICENSE = "LGPL"
+PR = "r2"
+
+inherit autotools
+
+SRC_URI = "http://burtonini.com/temp/${PN}-${PV}.tar.gz \
+ file://gtkstylus.sh"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/X11/Xsession.d
+ install -m 755 ${WORKDIR}/gtkstylus.sh ${D}/${sysconfdir}/X11/Xsession.d/45gtkstylus
+}
+
+# Horrible but rpm falls over if you use '*'
+GTKVER = "2.10.0"
+
+FILES_${PN} = "${sysconfdir} \
+ ${libdir}/gtk-2.0/${GTKVER}/modules/libgtkstylus.so.*"
+FILES_${PN}-dbg += "${libdir}/gtk-2.0/${GTKVER}/modules/.debug"
+FILES_${PN}-dev += "${libdir}/gtk-2.0/${GTKVER}/modules/libgtkstylus.so \
+ ${libdir}/gtk-2.0/${GTKVER}/modules/libgtkstylus.*a"