aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-11 07:41:37 -0700
committerKhem Raj <raj.khem@gmail.com>2022-04-11 07:47:11 -0700
commit3698e333b18867649a58320c9db245938839747f (patch)
tree31724cc101fdf181fca330d83c407da3ccf6ab86 /meta-gnome
parent6b25556d2f3463cfba57d38585673f6fd9910e14 (diff)
downloadmeta-openembedded-3698e333b18867649a58320c9db245938839747f.tar.gz
evolution-data-server: Disable g-i on musl
g-i calls on musl are adding -L/usr/lib to linker path which confuses the build as it tried to use the libraries from build host and fails badly Fixes aarch64-yoe-linux-musl-ld: warning: library search path "/usr/lib" is unsafe for cross-compilation ... | /mnt/b/yoe/master/build/tmp/work/cortexa72-yoe-linux-musl/evolution-data-server/3.44.0-r0/recipe-sysroot-native/usr/bin/aarch64-yoe-linux-musl/aarch64-yoe-linux-musl-ld: skipping incompa tible /usr/lib/libunwind.so when searching for -l:libunwind.so | Error relocating /usr/lib/libz.so.1: unsupported relocation type 8 | Error relocating /usr/lib/libz.so.1: unsupported relocation type 8 Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
index 48cf6f76bc..b4931d796d 100644
--- a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
@@ -48,6 +48,9 @@ PACKAGECONFIG[openldap] = "-DWITH_OPENLDAP=ON,-DWITH_OPENLDAP=OFF,openldap"
# -ldb needs this on some platforms
LDFLAGS += "-lpthread -lgmodule-2.0 -lgthread-2.0"
+# invokes libraries from build host
+GI_DATA_ENABLED:libc-musl="False"
+
do_configure:append () {
cp ${WORKDIR}/iconv-detect.h ${S}/src
# avoid writing perl-native path into csv2vcard shebang