aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2022-04-09 16:16:42 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-10 10:05:35 -0700
commit8d3ee7b2d83ce2106c7f3e7b5129a221cbfe4d7a (patch)
treea6c1846c40810221ac8471dfb5463b991e60a5f1 /meta-gnome
parent150581b6373b80f96060cc54cfc67873a779ed86 (diff)
downloadmeta-openembedded-8d3ee7b2d83ce2106c7f3e7b5129a221cbfe4d7a.tar.gz
gparted: update to v1.4.0
- remove x11 features-check because there aren't dependencies that would explicilty require x11 as a DISTRO_FEATURE - use POSIX basename() to fix up musl build ============================ GParted 1.4.0 (2022-03-28) ============================ Release Notes ------------- This release of GParted includes enhancements, bug fixes and language translation updates. * Add labelling of mounted btrfs, ext2/3/4 and xfs file systems * Fix detection of mount points for encrypted file systems * Fix crash scrolling quickly in the drive selection combobox * Add bcache detection * Add JBD external EXT3/4 journal detection Bug Fixes --------- * Add labelling of mounted btrfs, ext2/3/4 and xfs file systems (#163, !87) * Fix detection of mount points for encrypted file systems (#162, !88) * Fix unmount error when unmounting below a bind mount point (!89) * Fix crash scrolling quickly in the drive selection combobox (#165, !91) * Add initial Indonesian translation of help (!90) * Add accessibility relations for screen readers like Orca (!92) * Fix partition creation at sector 2048 if partition before it (#172, !93) * Make more getter methods use return-by-constant-reference (!94) * Check copy destination instead of source (!95) * Add bcache detection (#183, !96) * Add JBD external EXT3/4 journal detection (#89, !97) * Fix translation of DocBook markup tag of the GParted Manual (!98) Code Credits ------------ Code enhancements are courtesy of Movie Ma, Pascal Engélibert, and Mike Fleetwood. Translations (new/updated) -------------------------- cs(Marek Černocký), da(Alan Mortensen), eu(Asier Sarasua Garmendia), fur(Fabio Tomat), he(Yaron Shahrabani), hr(Goran Vidović), hu(Balázs Úr), id(Andika Triwidada), it(Milo Casagrande), ko(Seong-ho Cho), lt(Aurimas Černius), lv(Rūdolfs Mazurs), nb(Kjell Cato Heskjestad), nl(Nathan Follens), pa(A S Alam), pt(Hugo Carvalho), ru(Aleksandr Melman, Sergej A), sk(Dušan Kazik), sl(Matej Urbančič), sr(Мирослав Николић), zh_CN(Luming Zh) Dependencies (new/updated) -------------------------- * n/a Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-extended/gparted/files/0001-use-posix-basename.patch30
-rw-r--r--meta-gnome/recipes-extended/gparted/gparted_1.4.0.bb (renamed from meta-gnome/recipes-extended/gparted/gparted_1.3.1.bb)6
2 files changed, 33 insertions, 3 deletions
diff --git a/meta-gnome/recipes-extended/gparted/files/0001-use-posix-basename.patch b/meta-gnome/recipes-extended/gparted/files/0001-use-posix-basename.patch
new file mode 100644
index 0000000000..aae200e27e
--- /dev/null
+++ b/meta-gnome/recipes-extended/gparted/files/0001-use-posix-basename.patch
@@ -0,0 +1,30 @@
+Subject: [PATCH] BCache_Info.cc: use posix basename
+
+gnu 'basename' is undeclared for cplusplus if using musl. Use posix basename instead.
+
+fdebug-prefix-map=TOPDIR/build/tmp/work/cortexa57-yoe-linux-musl/gparted/1.4.0-r0/
+recipe-sysroot-native=-fvisibility-inlines-hidden -c -o Dialog_Disklabel.o ../../
+gparted-1.4.0/src/Dialog_Disklabel.cc ../../gparted-1.4.0/src/BCache_Info.cc:52:33:
+
+error: use of undeclared identifier 'basename'; did you mean 'g_basename'?
+ return "/dev/" + Glib::ustring(basename(buf));
+ ^~~~~~~~
+ g_basename
+
+Signed-off-by: Markus Volk <f_l_k@t-online.de>
+
+Upstream-Status: Submitted
+
+https://gitlab.gnome.org/GNOME/gparted/-/merge_requests/99
+
+--- a/src/BCache_Info.cc 2022-03-02 22:04:17.000000000 +0100
++++ b/src/BCache_Info.cc 2022-04-09 15:02:56.932218665 +0200
+@@ -17,7 +17,7 @@
+
+ #include "BCache_Info.h"
+
+-#include <string.h> // GNU version of basename()
++#include <libgen.h> // POSIX version of basename()
+ #include <unistd.h>
+ #include <glibmm/ustring.h>
+ #include <glibmm/fileutils.h>
diff --git a/meta-gnome/recipes-extended/gparted/gparted_1.3.1.bb b/meta-gnome/recipes-extended/gparted/gparted_1.4.0.bb
index d1a9759303..6f774904b7 100644
--- a/meta-gnome/recipes-extended/gparted/gparted_1.3.1.bb
+++ b/meta-gnome/recipes-extended/gparted/gparted_1.4.0.bb
@@ -3,16 +3,16 @@ HOMEPAGE = "http://gparted.org/index.php"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-inherit features_check autotools pkgconfig python3native gnome-help gtk-icon-cache
+inherit autotools pkgconfig python3native gnome-help gtk-icon-cache
-REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI = " \
${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
file://0001-Install-polkit-action-unconditionally-executable-pke.patch \
file://0001-Do-not-use-NULL-where-boolean-is-expected.patch \
+ file://0001-use-posix-basename.patch \
"
-SRC_URI[sha256sum] = "5eee2e6d74b15ef96b13b3a2310c868ed2298e03341021e7d12a5a98a1d1e109"
+SRC_URI[sha256sum] = "e5293a792e53fdbeba29c4a834113cd9603d0d639330da931a468bf3687887be"
UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/gparted/files/gparted/"
UPSTREAM_CHECK_REGEX = "gparted-(?P<pver>\d+\.(\d+)+(\.\d+)+)"