aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2022-04-16 21:40:12 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-18 10:12:51 -0700
commit9864902a15fcc5b0909a1520bf83827a5ad39809 (patch)
treec823754c7c452b7c5f5872d0910e2da959d1bea3 /meta-gnome
parent6fbe7f748706229f43a2e06b08b6e1e729942314 (diff)
downloadmeta-openembedded-9864902a15fcc5b0909a1520bf83827a5ad39809.tar.gz
libgweather4: Fix introspection build
Missing libgweather4-gir is a gnome-session blocker: | raspberrypi4-64 systemd[2783]: Failed to start GNOME Shell on Wayland. | raspberrypi4-64 systemd[2783]: org.gnome.Shell@wayland.service: Failed with result 'protocol'. | raspberrypi4-64 gnome-shell[4698]: Execution of main.js threw exception: Module resource:///org/gnome/shell/ui/init.js threw an exception | raspberrypi4-64 gnome-shell[4698]: JS ERROR: Error: Requiring GWeather, version 4.0: Typelib file for namespace 'GWeather', version '4.0' not found Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/libgweather/libgweather4/0001-Allow-building-gir-in-cross-environments.patch33
-rw-r--r--meta-gnome/recipes-gnome/libgweather/libgweather4_4.0.0.bb7
2 files changed, 35 insertions, 5 deletions
diff --git a/meta-gnome/recipes-gnome/libgweather/libgweather4/0001-Allow-building-gir-in-cross-environments.patch b/meta-gnome/recipes-gnome/libgweather/libgweather4/0001-Allow-building-gir-in-cross-environments.patch
new file mode 100644
index 0000000000..6c6a643edf
--- /dev/null
+++ b/meta-gnome/recipes-gnome/libgweather/libgweather4/0001-Allow-building-gir-in-cross-environments.patch
@@ -0,0 +1,33 @@
+From 179102310e9a3729fb5b00f2a7bf24b12f4a7a83 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Sat, 16 Apr 2022 20:04:14 +0200
+Subject: [PATCH] Allow building gir in cross environments
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+For us this works perfectly fine
+
+Upstream-Status: Inappropriate [OE-specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ libgweather/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libgweather/meson.build b/libgweather/meson.build
+index 08311af..ef554f2 100644
+--- a/libgweather/meson.build
++++ b/libgweather/meson.build
+@@ -208,7 +208,7 @@ lib_libgweather = library('gweather-4',
+ )
+
+ g_ir_scanner = find_program('g-ir-scanner', required: get_option('introspection'))
+-build_gir = get_option('introspection') and g_ir_scanner.found() and not meson.is_cross_build()
++build_gir = get_option('introspection') and g_ir_scanner.found()
+
+ enable_vala = get_option('enable_vala')
+ vapigen = find_program('vapigen', required: enable_vala == 'true')
+--
+2.34.1
+
diff --git a/meta-gnome/recipes-gnome/libgweather/libgweather4_4.0.0.bb b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.0.0.bb
index acfb97655a..708d27a61f 100644
--- a/meta-gnome/recipes-gnome/libgweather/libgweather4_4.0.0.bb
+++ b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.0.0.bb
@@ -7,14 +7,11 @@ GNOMEBASEBUILDCLASS = "meson"
GNOMEBN = "libgweather"
S = "${WORKDIR}/${GNOMEBN}-${PV}"
-inherit gnomebase gsettings gobject-introspection gettext gtk-doc vala features_check upstream-version-is-even
+inherit gnomebase gsettings gobject-introspection gettext gtk-doc vala
+SRC_URI += "file://0001-Allow-building-gir-in-cross-environments.patch"
SRC_URI[archive.sha256sum] = "440d44801b6f72b48c676e5e37f9109cfee1394fd74cc92725e1b1ba4fae834c"
-# gobject-introspection is mandatory and cannot be configured
-REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
-GIR_MESON_OPTION = ""
-
GTKDOC_MESON_OPTION = "gtk_doc"
DEPENDS = " \