aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2022-04-12 08:54:30 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-13 19:21:40 -0700
commita48c6c98e80103767225b7e49d43b6494292e75e (patch)
treefa9dc5c5c30b86e8a09e360ae4730a9b90b4b43b /meta-gnome
parentbad130a8dfa865bc53200342dbb55cd3272526c1 (diff)
downloadmeta-openembedded-a48c6c98e80103767225b7e49d43b6494292e75e.tar.gz
ibus: upgrade 1.5.23+ -> 1.5.26
1.5.26 * Enhance compose keys df664b1 19377ad * Enhance Emoji features acc5570 104148b d9ff2bb * Implement clear preedit for GTK4 5487a6b * Calculate keycode from keysym in GTK3 forward-key-event 4957d14 * Fix to send char position at update_preedit_text f5757ad * Deprecate gettext.bind_textdomain_codeset() since Python 3.8 28acfd4 * Fix ibus_key_event_from_string for gobject-introspection c69b61a * Fix a key event loop with forwarding keys 6b979e7 * Delete gnome-autogen dependency 2bc47f0 * Change XKB layout string color in panel 0e118e7 * Add IBUS_INPUT_HINT_PRIVATE for browser private mode 0f1485b * mkdir socket dirs instead of socket paths 787b564 dfd3fbf * Add org.freedesktop.IBus.session.generic.service b5423f0 * Check XDG_SESSION_DESKTOP for Plasma desktop 1f27521 * Update simple.xml with xkeyboard-config 2.35.1 a3c0724 * Update ibusunicodegen.h with unicode-ucd 14.0.0 9bf9ef0 * Enhance CI fbea544 51e3295 d53d31d be17934 675b94f * Fix typos a82bda5 1.5.25 * src/tests: Run gnome-session with no-overview mode 214b60a bc7811c ab6b958 * client/gtk2: Implement ibus_im_context_set_surrounding_with_selection() d105a39 * Code reviews e9e1642 17ae266 * src/ibuscomposetable: Do not include the same compose file a755d16 * src/ibusenginesimple: Multi_key to 0xB7 7e12d58 2fc1a02 * src/ibusenginesimple: Make Compose preedit less intrusive 3e2609e df49566 4259f16 5bd2ecc * Change default Emoji shortcut key b952d30 * setup: Enhance engine search function a4939f6 * client/gtk2/ibusimcontext: Enable sync process in GTK4 a823161 * engine: Update simple.xml with xkeyboard-config 2.33 934c456 238eb61 1.5.24 * Add GTK4 IM module c7928b1 d0a47c3 * Search engine name directly ef4c5c7 * Update IBusInputPurpose and IBusInputHints in ibustypes.h b72efea * Warn deprecated IBus XKB engines /w dialog 5322c44 * Update simple.xml 5012b69 * Add CI 30a3641 * Fix arguments in GLib.DBusSignalCallback for Vala 0.50 dd4cc5b * Fix to build emoji-*.dict in CLDR 38 aa558de * Fix build environments 02338ce 5d68b00 29959e1 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-support/ibus/ibus.bb6
-rw-r--r--meta-gnome/recipes-support/ibus/ibus.inc6
2 files changed, 8 insertions, 4 deletions
diff --git a/meta-gnome/recipes-support/ibus/ibus.bb b/meta-gnome/recipes-support/ibus/ibus.bb
index 2d733ce53e..be43d0d500 100644
--- a/meta-gnome/recipes-support/ibus/ibus.bb
+++ b/meta-gnome/recipes-support/ibus/ibus.bb
@@ -15,8 +15,8 @@ EXTRA_OECONF += "--with-ucd-dir=${STAGING_DATADIR}/unicode/ucd"
PACKAGECONFIG ??= " \
dconf vala \
- ${@bb.utils.contains_any('DISTRO_FEATURES', [ 'wayland', 'x11' ], 'gtk3', '', d)} \
- ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)} \
+ ${@bb.utils.contains_any('DISTRO_FEATURES', [ 'wayland', 'x11' ], 'gtk3 gtk4', '', d)} \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
"
do_configure:prepend() {
@@ -29,6 +29,8 @@ FILES:${PN} += " \
${datadir}/GConf \
${datadir}/glib-2.0 \
${libdir}/gtk-3.0 \
+ ${libdir}/gtk-4.0 \
+ ${systemd_user_unitdir} \
"
FILES:${PN}-dev += " \
diff --git a/meta-gnome/recipes-support/ibus/ibus.inc b/meta-gnome/recipes-support/ibus/ibus.inc
index 23f565f661..37a490abe0 100644
--- a/meta-gnome/recipes-support/ibus/ibus.inc
+++ b/meta-gnome/recipes-support/ibus/ibus.inc
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
inherit autotools-brokensep pkgconfig gobject-introspection gettext gtk-doc vala
-PV = "1.5.23+git${SRCPV}"
+PV = "1.5.26"
DEPENDS = "unicode-ucd"
@@ -13,13 +13,15 @@ SRC_URI = " \
git://github.com/ibus/ibus.git;branch=master;protocol=https \
file://0001-Do-not-try-to-start-dbus-we-do-not-have-dbus-lauch.patch \
"
-SRCREV = "dd4cc5b028c35f9bb8fa9d3bdc8f26bcdfc43d40"
+SRCREV = "6a70ab0338206bd1c7d01a4e1874ea0ee5b3a9d3"
S = "${WORKDIR}/git"
PACKAGECONFIG[appindicator] = "--enable-appindicator,--disable-appindicator,qtbase"
PACKAGECONFIG[dconf] = "--enable-dconf,--disable-dconf,dconf"
PACKAGECONFIG[gtk2] = "--enable-gtk2,--disable-gtk2,gtk+"
PACKAGECONFIG[gtk3] = "--enable-gtk3,--disable-gtk3,gtk+3"
+PACKAGECONFIG[gtk4] = "--enable-gtk4,--disable-gtk4,gtk4"
+PACKAGECONFIG[systemd] = "--enable-systemd-services,--disable-systemd-services,systemd"
PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland"
PACKAGECONFIG[vala] = "--enable-vala,--disable-vala"
PACKAGECONFIG[x11] = "--enable-xim --enable-ui,--disable-xim --disable-ui,virtual/libx11"