aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2022-04-13 00:26:37 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-13 19:21:41 -0700
commita89b57aa45b08c1b90b9d46b0ff97fea6b65a7be (patch)
tree44bdfab6cf1e6cd432f5f7c6bd35f1c5ff4c207e /meta-gnome
parent6f5d694d9c328a9d8e0bd927d569714cd75597b7 (diff)
downloadmeta-openembedded-a89b57aa45b08c1b90b9d46b0ff97fea6b65a7be.tar.gz
gnome-bluetooth: rename recipes to avoid suffix in future
We have two gnome-bluetooths: * 3.34.5: This will deprecate so add suffix and name it gnome-bluetooth3 * 42.0: This is the future of gnome-bluetooth so name it as such Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3/0001-build-Fix-build-for-newer-versions-of-meson.patch (renamed from meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-build-Fix-build-for-newer-versions-of-meson.patch)0
-rw-r--r--meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3_3.34.5.bb (renamed from meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.34.5.bb)10
-rw-r--r--meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.0.bb (renamed from meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth4_42.0.bb)7
-rw-r--r--meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_42.0.bb2
-rw-r--r--meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.44.0.bb2
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb2
-rw-r--r--meta-gnome/recipes-support/packagegroups/packagegroup-gnome-desktop.bb2
7 files changed, 14 insertions, 11 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-build-Fix-build-for-newer-versions-of-meson.patch b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3/0001-build-Fix-build-for-newer-versions-of-meson.patch
index 16c87b6a63..16c87b6a63 100644
--- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-build-Fix-build-for-newer-versions-of-meson.patch
+++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3/0001-build-Fix-build-for-newer-versions-of-meson.patch
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.34.5.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3_3.34.5.bb
index 7b74c76f92..e2a885b1fb 100644
--- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.34.5.bb
+++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth3_3.34.5.bb
@@ -8,6 +8,9 @@ SECTION = "x11/gnome"
DEPENDS = "udev gtk+3 libnotify libcanberra bluez5"
+GNOMEBN = "gnome-bluetooth"
+S = "${WORKDIR}/${GNOMEBN}-${PV}"
+
GNOMEBASEBUILDCLASS = "meson"
GTKDOC_MESON_OPTION = "gtk_doc"
@@ -22,13 +25,16 @@ SRC_URI += " file://0001-build-Fix-build-for-newer-versions-of-meson.patch"
SRC_URI[archive.md5sum] = "d83faa54abaf64bb40b5313bc233e74e"
SRC_URI[archive.sha256sum] = "6c949e52c8becc2054daacd604901f66ce5cf709a5fa91c4bb7cacc939b53ea9"
-# avoid clashes with gnome-bluetooth4
+# avoid clashes with gnome-bluetooth
do_install:append() {
# just bluetooth-sendto / bluetooth-sendto.desktop only
rm -rf ${D}${bindir}
rm -rf ${D}${datadir}/applications
}
+
+FILES:${PN} += "${datadir}/gnome-bluetooth"
+
# offer alternate bluetooth-sendto
-RRECOMMENS:${PN} += "gnome-bluetooth4"
+RRECOMMENS:${PN} += "gnome-bluetooth"
RDEPENDS:${PN} += "bluez5"
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth4_42.0.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.0.bb
index 3fe2c35ef4..a9b7bdec09 100644
--- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth4_42.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_42.0.bb
@@ -18,9 +18,6 @@ DEPENDS = " \
libadwaita \
"
-GNOMEBN = "gnome-bluetooth"
-S = "${WORKDIR}/${GNOMEBN}-${PV}"
-
GNOMEBASEBUILDCLASS = "meson"
GTKDOC_MESON_OPTION = "gtk_doc"
GTKIC_VERSION = "4"
@@ -31,6 +28,6 @@ REQUIRED_DISTRO_FEATURES = "x11"
SRC_URI[archive.sha256sum] = "3d1e2720673bc9a242619dc5d231fd6e776c18a49da29f43cdc433055adb0170"
-RDEPENDS:${PN} += "bluez5"
-
FILES:${PN} += "${datadir}/gnome-bluetooth-3.0"
+
+RDEPENDS:${PN} += "bluez5"
diff --git a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_42.0.bb b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_42.0.bb
index 16b62abeff..6fe999a191 100644
--- a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_42.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_42.0.bb
@@ -21,7 +21,7 @@ DEPENDS = " \
gnome-desktop \
gnome-online-accounts \
libnma \
- gnome-bluetooth4 \
+ gnome-bluetooth \
grilo \
libgtop \
gsound \
diff --git a/meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.44.0.bb b/meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.44.0.bb
index 3c41ea9bc2..1e357af875 100644
--- a/meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.44.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.44.0.bb
@@ -14,7 +14,7 @@ DEPENDS += " \
metacity \
gdm \
gnome-desktop \
- gnome-bluetooth \
+ gnome-bluetooth3 \
gnome-panel \
"
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb
index fd9a35d802..f54d966c73 100644
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_42.0.bb
@@ -35,7 +35,7 @@ SRC_URI[archive.sha256sum] = "33d404fb3c93b9de42984f0110a2969d6a4a7247c27fe7f5e2
SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
-PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth4"
+PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanager"
PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
diff --git a/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-desktop.bb b/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-desktop.bb
index beea062777..13394ca1db 100644
--- a/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-desktop.bb
+++ b/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-desktop.bb
@@ -14,7 +14,7 @@ RDEPENDS:${PN} = " \
adwaita-icon-theme-cursors \
evolution-data-server \
gnome-backgrounds \
- gnome-bluetooth4 \
+ gnome-bluetooth \
gnome-control-center \
gnome-desktop \
gnome-flashback \