aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-01-14 13:00:47 +0100
committerKhem Raj <raj.khem@gmail.com>2020-01-14 14:40:52 -0800
commit57394d5ec611347b28e2bdabcc2cad505cbb76c8 (patch)
treecdb8bc2847a8b33ff3f3a789167fecbde2b8c69b /meta-gnome
parent84e87356aa7fcd3190b288702f971b6b5c1b8b6f (diff)
downloadmeta-openembedded-57394d5ec611347b28e2bdabcc2cad505cbb76c8.tar.gz
sysprof: fix ARM builds
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch42
-rw-r--r--meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb4
2 files changed, 44 insertions, 2 deletions
diff --git a/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch b/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
new file mode 100644
index 0000000000..2354892265
--- /dev/null
+++ b/meta-gnome/recipes-kernel/sysprof/files/0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch
@@ -0,0 +1,42 @@
+From 43c39b5685445242d071b3706af2903efa508b4a Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 14 Jan 2020 12:58:27 +0100
+Subject: [PATCH] meson.build: do not hardcode 'linux' as
+ host_machine().system() value
+
+In some build environmets such as OpenEmbedded this can be 'linux-gnueabi'
+or otherwise not exactly 'linux'.
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ src/libsysprof/meson.build | 2 +-
+ src/tools/meson.build | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/libsysprof/meson.build b/src/libsysprof/meson.build
+index 3449961..3c2d186 100644
+--- a/src/libsysprof/meson.build
++++ b/src/libsysprof/meson.build
+@@ -84,7 +84,7 @@ libsysprof_deps = [
+ polkit_dep,
+ ]
+
+-if host_machine.system() == 'linux'
++if host_machine.system().contains('linux')
+ libsysprof_public_sources += [
+ 'sysprof-memory-source.c',
+ 'sysprof-perf-counter.c',
+diff --git a/src/tools/meson.build b/src/tools/meson.build
+index 670052a..3fb7f0c 100644
+--- a/src/tools/meson.build
++++ b/src/tools/meson.build
+@@ -2,7 +2,7 @@ tools_deps = [
+ libsysprof_capture_dep,
+ ]
+
+-if get_option('libsysprof') and host_machine.system() == 'linux'
++if get_option('libsysprof') and host_machine.system().contains('linux')
+ polkit_agent_dep = dependency('polkit-agent-1')
+ sysprof_cli = executable('sysprof-cli', 'sysprof-cli.c',
+ dependencies: tools_deps + [libsysprof_dep, polkit_dep, polkit_agent_dep],
diff --git a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
index b7e7bee6bb..fd1b77eced 100644
--- a/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
+++ b/meta-gnome/recipes-kernel/sysprof/sysprof_3.34.1.bb
@@ -11,8 +11,8 @@ DEPENDS = "glib-2.0 libxml2-native glib-2.0-native"
SRC_URI[archive.md5sum] = "cc32455277b31afb1965d627ae3e3629"
SRC_URI[archive.sha256sum] = "844bbb8d8b65071b3bca96f8e921319ceef81f2d2c51fcc9da63a4b355c893d0"
-SRC_URI += " \
- file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \
+SRC_URI += "file://0001-sysprof-Define-NT_GNU_BUILD_ID-if-undefined.patch \
+ file://0001-meson.build-do-not-hardcode-linux-as-host_machine-.s.patch \
"
PACKAGECONFIG ?= "sysprofd libsysprof ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"