aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gpe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-04-18 11:02:33 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-04-18 11:02:33 +0200
commite402205cb53d2180b32a2071951e561e7134ae01 (patch)
tree4f04d8fa290584c4110398e61b454cc7ce17c9ae /meta-gpe
parentc1e4031179842027809b9abae97d4182a0c00e73 (diff)
downloadmeta-openembedded-e402205cb53d2180b32a2071951e561e7134ae01.tar.gz
libgpe-widget: import from OE .dev a263524ca222f1968507489313211b4fa674e963
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gpe')
-rw-r--r--meta-gpe/recipes-graphics/libgpewidget/libgpewidget/pkgconfig.patch11
-rw-r--r--meta-gpe/recipes-graphics/libgpewidget/libgpewidget_0.117.bb24
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-gpe/recipes-graphics/libgpewidget/libgpewidget/pkgconfig.patch b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget/pkgconfig.patch
new file mode 100644
index 0000000000..317e01a9b4
--- /dev/null
+++ b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget/pkgconfig.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2006-02-04 17:37:55.000000000 +0100
++++ configure.ac 2006-02-06 00:56:28.000000000 +0100
+@@ -36,7 +36,7 @@
+ ENABLE_CAIRO=$enableval
+ ],
+ [
+- PKG_CHECK_EXISTS(cairo, [ENABLE_CAIRO=yes], [ENABLE_CAIRO=no])
++ PKG_CHECK_MODULES(cairo, [ENABLE_CAIRO=yes], [ENABLE_CAIRO=no])
+ ])
+
+ ENABLE_HILDON=false
diff --git a/meta-gpe/recipes-graphics/libgpewidget/libgpewidget_0.117.bb b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget_0.117.bb
new file mode 100644
index 0000000000..ca5b66c73b
--- /dev/null
+++ b/meta-gpe/recipes-graphics/libgpewidget/libgpewidget_0.117.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "libgpewidget contains a collection of widgets and other common code shared by many GPE applications."
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=d8045f3b8f929c1cb29a1e3fd737b499"
+
+DEPENDS = "gtk+ cairo libxinerama libxcomposite libxrender gtk-doc"
+PR = "r0"
+
+SRC_URI += "file://pkgconfig.patch;striplevel=0"
+SRC_URI[md5sum] = "b85a839264a35d0faf9a1a38c486e189"
+SRC_URI[sha256sum] = "f96d30c09b0395ea4e146730fd52d9ea303b619bb139051d9f12d3f868a9e18c"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit gpe pkgconfig autotools
+
+EXTRA_OECONF = "--enable-cairo"
+LDFLAGS += " -L${STAGING_LIBDIR}"
+
+PACKAGES =+ "libgpewidget-bin"
+FILES_libgpewidget-bin = "${bindir}/*"
+