aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-06-17 13:34:49 -0700
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commit9ecd1e0e1395d1af605260c3617e700563205eef (patch)
treed4a7be9225d140042c13865ab400874bba372aad /meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
parent2be8e0fe2f61685758e0f0b2508e950d4cb7c805 (diff)
downloadmeta-openembedded-9ecd1e0e1395d1af605260c3617e700563205eef.tar.gz
libebml: don't rely on make -e, obey LDFLAGS
We need to obey LDFLAGS to get the correct hash style for external toolchains, and passing vars explicitly is better than relying on implicitly overriding everything blindly from the environment. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 64d874f768207a8a1e27a5c6edd3abe90607af03) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb')
-rw-r--r--meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb44
1 files changed, 39 insertions, 5 deletions
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb b/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
index 71e2bfc567..b756a39249 100644
--- a/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
+++ b/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
@@ -2,15 +2,49 @@ SUMMARY = "libebml is a C++ libary to parse EBML files"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=f14599a2f089f6ff8c97e2baa4e3d575"
-SRC_URI = "http://dl.matroska.org/downloads/libebml/libebml-${PV}.tar.bz2"
+SRC_URI = "\
+ http://dl.matroska.org/downloads/libebml/libebml-${PV}.tar.bz2 \
+ file://ldflags.patch \
+ file://override-uname.patch \
+"
SRC_URI[md5sum] = "efec729bf5a51e649e1d9d1f61c0ae7a"
SRC_URI[sha256sum] = "83b074d6b62715aa0080406ea84d33df2e44b5d874096640233a4db49b8096de"
-EXTRA_OEMAKE = "-e MAKEFLAGS="
+do_unpack[postfuncs] += "dos2unix"
-do_compile() {
- cd ${S}/make/linux
- oe_runmake CROSS="${TARGET_PREFIX}"
+dos2unix () {
+ cr="$(printf '\r')"
+ for f in make/*/Makefile; do
+ tr -d "$cr" <"$f" >"$f.new" && \
+ mv "$f.new" "$f"
+ done
+}
+
+LIBEBML_OS = "Unknown"
+LIBEBML_OS_linux = "Linux"
+LIBEBML_OS_darwin = "Darwin"
+LIBEBML_OS_mingw32 = "Windows"
+
+EXTRA_OEMAKE = "\
+ 'TARGET_OS=${LIBEBML_OS}' \
+ \
+ 'CXX=${CXX}' \
+ 'LD=${CXX}' \
+ 'AR=${AR}' \
+ 'RANLIB=${RANLIB}' \
+ \
+ 'DEBUGFLAGS=' \
+ 'CPPFLAGS=${CPPFLAGS}' \
+ 'CXXFLAGS=${CXXFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+ \
+ 'prefix=${prefix}' \
+ 'libdir=${libdir}' \
+ 'includedir=${includedir}/ebml' \
+"
+
+do_compile () {
+ oe_runmake -C make/linux
}
do_install() {