aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-01-16 22:41:54 +0100
committerKhem Raj <raj.khem@gmail.com>2019-01-16 16:33:11 -0800
commit950331a6f53cb25af81e1537cc14591eb3d8e20b (patch)
tree6adf2649be5902f083c6e3c0bbd7aebba6ebbbb4 /meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb
parenta368821c96bc041a8d7f7dab7d4a653d59729d0e (diff)
downloadmeta-openembedded-950331a6f53cb25af81e1537cc14591eb3d8e20b.tar.gz
fluidsynth: upgrade 1.1.11 -> 2.0.3
* Fallout caused by API change should be fixed in all recipes depending fluidsynth. To make this happen I sent out patches to many projects during last autumn. * Add PACKAGECONFIG for profiling (disabled by default). * ARM-NEON-patch was reworked and profiling runs were performed with and without the patch. See patch description for profiling results. * We need to split tool to generate parameter tables to native. Since target and native builds do not share much in common we don't use BBCALLSEXTEND * Add patch which allows clients to reduce useless copies of buffers. Fluidsynth-DSSI (in meta-qt5-extra currently) is going to make use of this. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb')
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb
new file mode 100644
index 0000000000..4f600a218d
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_git.bb
@@ -0,0 +1,22 @@
+require ${BPN}.inc
+
+DEPENDS = "${BPN}-native alsa-lib ncurses glib-2.0"
+
+SRC_URI += " \
+ file://0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch \
+ file://0002-fluid_synth_nwrite_float-Allow-zero-pointer-for-left.patch \
+ file://0003-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch \
+"
+
+EXTRA_OECMAKE = "-Denable-floats=ON -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
+
+do_configure_append() {
+ make_tables.exe ${B}/
+}
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}"
+PACKAGECONFIG[sndfile] = "-Denable-libsndfile=ON,-Denable-libsndfile=OFF,libsndfile1"
+PACKAGECONFIG[jack] = "-Denable-jack=ON,-Denable-jack=OFF,jack"
+PACKAGECONFIG[pulseaudio] = "-Denable-pulseaudio=ON,-Denable-pulseaudio=OFF,pulseaudio"
+PACKAGECONFIG[portaudio] = "-Denable-portaudio=ON,-Denable-portaudio=OFF,portaudio-v19"
+PACKAGECONFIG[profiling] = "-Denable-profiling=ON,-Denable-profiling=OFF"