aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/vlc/vlc
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-10-11 19:47:24 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-14 11:48:57 +0200
commit95d78c37107fe6f11238a020fb5ce11ce76e9635 (patch)
tree5403b75f9a614e49ee56438860ee3a83fdc0fb6a /meta-multimedia/recipes-multimedia/vlc/vlc
parentf48e71ec3e3401231eb66fc810e7c18f0e659b47 (diff)
downloadmeta-openembedded-95d78c37107fe6f11238a020fb5ce11ce76e9635.tar.gz
vlc: make opencv explicitly configurable
World builds are failing due to change in opencv in API. Since vlc is only using opencv as an example and a filter, disable by default. Revisit when upstream adapts to new opencv API. Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/vlc/vlc')
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch
new file mode 100644
index 0000000000..950c09b8ae
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch
@@ -0,0 +1,29 @@
+Recent opencv API changes break upstream filter and example.
+Make opencv explicitly configurable.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Tim Orling <TicoTimo@gmail.com>
+
+Index: vlc-2.1.4/configure.ac
+===================================================================
+--- vlc-2.1.4.orig/configure.ac
++++ vlc-2.1.4/configure.ac
+@@ -1693,7 +1693,16 @@ PKG_ENABLE_MODULES_VLC([BLURAY], [libblu
+ dnl
+ dnl OpenCV wrapper and example filters
+ dnl
+-PKG_ENABLE_MODULES_VLC([OPENCV], [opencv_example opencv_wrapper], [opencv > 2.0], (OpenCV (computer vision) filter), [auto])
++AC_ARG_ENABLE(opencv,
++ [AS_HELP_STRING([--disable-opencv],
++ [disable OpenCV computer vision filter and example (default auto)])])
++if test "${enable_opencv}" != "no"
++then
++ PKG_ENABLE_MODULES_VLC([OPENCV],
++ [opencv_example opencv_wrapper],
++ [opencv > 2.0],
++ (OpenCV (computer vision) filter), [auto])
++fi
+
+
+ dnl