aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-01-17 09:34:18 +0100
committerArmin Kuster <akuster808@gmail.com>2018-01-22 19:40:02 -0800
commitaa0b4aecad6d837099b1c7256a4eb46a75365d5e (patch)
tree581293d59daab0f4631f277d57c303433e002186 /meta-multimedia/recipes-multimedia
parentcd388605bf0e5a4747cfa155b0747af650c5b5a1 (diff)
downloadmeta-openembedded-aa0b4aecad6d837099b1c7256a4eb46a75365d5e.tar.gz
fluidsynth: update 1.1.8 -> 1.1.9
* 0001-avoid-buffer-overrun-in-fluid_synth_nwrite_float.patch was applied upstream Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/files/0001-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch (renamed from meta-multimedia/recipes-multimedia/fluidsynth/files/0002-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch)0
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/files/0001-avoid-buffer-overrun-in-fluid_synth_nwrite_float.patch32
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.9.bb (renamed from meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb)5
3 files changed, 2 insertions, 35 deletions
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/files/0002-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch b/meta-multimedia/recipes-multimedia/fluidsynth/files/0001-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch
index 0e1846e31c..0e1846e31c 100644
--- a/meta-multimedia/recipes-multimedia/fluidsynth/files/0002-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/files/0001-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/files/0001-avoid-buffer-overrun-in-fluid_synth_nwrite_float.patch b/meta-multimedia/recipes-multimedia/fluidsynth/files/0001-avoid-buffer-overrun-in-fluid_synth_nwrite_float.patch
deleted file mode 100644
index dda76cfee6..0000000000
--- a/meta-multimedia/recipes-multimedia/fluidsynth/files/0001-avoid-buffer-overrun-in-fluid_synth_nwrite_float.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From a13cb63103aa56b5e8bad816c7d13d6e01c0cd9f Mon Sep 17 00:00:00 2001
-From: derselbst <tom.mbrt@googlemail.com>
-Date: Sun, 26 Nov 2017 22:12:12 +0100
-Subject: [PATCH 1/2] avoid buffer overrun in fluid_synth_nwrite_float()
-
-Upstream-Status: Backport [1]
-
-[1] https://github.com/FluidSynth/fluidsynth/commit/a13cb63103aa56b5e8bad816c7d13d6e01c0cd9f
----
- src/synth/fluid_synth.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/synth/fluid_synth.c b/src/synth/fluid_synth.c
-index 266d759..14f6b21 100644
---- a/src/synth/fluid_synth.c
-+++ b/src/synth/fluid_synth.c
-@@ -2752,10 +2752,10 @@ fluid_synth_nwrite_float(fluid_synth_t* synth, int len,
- {
- #ifdef WITH_FLOAT
- if(fx_left != NULL)
-- FLUID_MEMCPY(fx_left[i + count], fx_left_in[i], bytes);
-+ FLUID_MEMCPY(fx_left[i] + count, fx_left_in[i], bytes);
-
- if(fx_right != NULL)
-- FLUID_MEMCPY(fx_right[i + count], fx_right_in[i], bytes);
-+ FLUID_MEMCPY(fx_right[i] + count, fx_right_in[i], bytes);
- #else //WITH_FLOAT
- int j;
- if(fx_left != NULL) {
---
-2.9.5
-
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.9.bb
index 406bbf7688..fffbf0cae3 100644
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.8.bb
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth_1.1.9.bb
@@ -8,10 +8,9 @@ DEPENDS = "alsa-lib ncurses glib-2.0"
SRC_URI = " \
git://github.com/FluidSynth/fluidsynth.git;branch=1.1.x \
- file://0001-avoid-buffer-overrun-in-fluid_synth_nwrite_float.patch \
- file://0002-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch \
+ file://0001-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch \
"
-SRCREV = "12e7afe3a806a6b397f28e0ca4bc6bab9ebe7047"
+SRCREV = "fe37923393d6a76f42ed044aa56dadc66ec909ce"
S = "${WORKDIR}/git"
inherit cmake pkgconfig lib_package