aboutsummaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-05-30 21:31:55 +0200
committerArmin Kuster <akuster808@gmail.com>2020-06-12 09:32:24 -0700
commit691d9087e93a238f47c2fcc0aabbd7041b8f25e1 (patch)
tree4b61bfdb80f248ef122fd4f279d8a0ca331da118 /meta-multimedia
parentd925460cfeceb473bc87e00534f490d915a9734b (diff)
downloadmeta-openembedded-691d9087e93a238f47c2fcc0aabbd7041b8f25e1.tar.gz
fluidsynth: upgrade 2.1.2 -> 2.1.3
>From [1]: * fix a cross-compilation failure from Win32 to WinARM (#630) * fix issues while fluid_player is seeking (#634, #646) * fix a NULL pointer dereference if synth.dynamic-sample-loading is enabled (#635) * fix a NULL pointer dereference in delete_rvoice_mixer_threads() (#640) * fix a NULL pointer dereference in the soundfont loader (#647, thanks to @jjceresa) * fix dsound driver playing garbage when terminating fluidsynth (#642, thanks to @jjceresa) * avoid memory leaks when using libinstpatch (#643) [1] https://github.com/FluidSynth/fluidsynth/releases/tag/v2.1.3 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 074e115397aca40eaa3c531653a8db75578c718f) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc4
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch32
2 files changed, 24 insertions, 12 deletions
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
index 73858b0203..fcc9df8c30 100644
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
@@ -5,8 +5,8 @@ LICENSE = "LGPL-2.1"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
SRC_URI = "git://github.com/FluidSynth/fluidsynth.git"
-SRCREV = "d9ad6a0725840388a48f45e38eda903a65ec1cf5"
+SRCREV = "19a20eb8526465fdf940b740b13462d71e190a1a"
S = "${WORKDIR}/git"
-PV = "2.1.2"
+PV = "2.1.3"
inherit cmake pkgconfig lib_package
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
index 44612275c1..cc73bdb1d9 100644
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
@@ -10,28 +10,40 @@ Upstream-Status: Inappropriate [embedded specific]
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
---
- src/CMakeLists.txt | 11 -----------
- 1 file changed, 11 deletions(-)
+ src/CMakeLists.txt | 23 +----------------------
+ 1 file changed, 1 insertion(+), 22 deletions(-)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index a0ba53d1..1c626717 100644
+index 356bb734..58ff7635 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -359,14 +359,3 @@ else ( MACOSX_FRAMEWORK )
- )
+@@ -399,25 +399,4 @@ else ( MACOSX_FRAMEWORK )
install ( FILES ${public_main_HEADER} DESTINATION ${INCLUDE_INSTALL_DIR} )
endif ( MACOSX_FRAMEWORK )
--
+
-# ******* Auto Generated Lookup Tables ******
-
-include(ExternalProject)
+-
+-set (GENTAB_SDIR ${CMAKE_CURRENT_SOURCE_DIR}/gentables)
+-set (GENTAB_BDIR ${CMAKE_CURRENT_BINARY_DIR}/gentables)
+-
+-# Use external project to ensure that cmake uses the host compiler when building make_tables.exe
+-# To fix cross-compiling fluidsynth from Win32 to ARM (using vcpkg), we need to pass the current generator
+-# on to the external project, otherwise (for some unknown reason) the target compiler will be used rather
+-# than the host compiler.
-ExternalProject_Add(gentables
- DOWNLOAD_COMMAND ""
-- SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/gentables
-- BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/gentables
-- INSTALL_COMMAND ${CMAKE_CURRENT_BINARY_DIR}/gentables/make_tables.exe "${CMAKE_BINARY_DIR}/"
+- SOURCE_DIR ${GENTAB_SDIR}
+- BINARY_DIR ${GENTAB_BDIR}
+- CONFIGURE_COMMAND
+- "${CMAKE_COMMAND}" -DCMAKE_VERBOSE_MAKEFILE=${CMAKE_VERBOSE_MAKEFILE} -G "${CMAKE_GENERATOR}" -B "${GENTAB_BDIR}" "${GENTAB_SDIR}"
+- BUILD_COMMAND
+- "${CMAKE_COMMAND}" --build "${GENTAB_BDIR}"
+- INSTALL_COMMAND ${GENTAB_BDIR}/make_tables.exe "${CMAKE_BINARY_DIR}/"
-)
-add_dependencies(libfluidsynth-OBJ gentables)
++
--
-2.14.5
+2.21.1