aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/samba
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-11-17 13:37:35 +0800
committerArmin Kuster <akuster808@gmail.com>2017-01-29 19:14:34 -0500
commit6f1f4e30076d8af2e03d946b0947fe65c2bae5a2 (patch)
treeb8d36e016772cbef0e6bb8796c63f59936179b0f /meta-networking/recipes-connectivity/samba
parent37291d104b1e9e445fef6dc32bb0d3b882cc6608 (diff)
downloadmeta-openembedded-6f1f4e30076d8af2e03d946b0947fe65c2bae5a2.tar.gz
samba: Fix qa issue and update ctdb-tests
Fix file-rdeps QA warning by replace shell interpreter of script ${bindir}/onnode with /bin/sh that it doesn't has any bashism. File ${bindir}/ctdb_run_cluster_tests which is a link to ${bindir}/ctdb_run_tests is split into package samba. That causes wrong runtime dependency that samba depends on samba-ctdb-tests. Split the file to samba-ctdb-tests to fix the issue. Script ctdb_run_tests calls command 'getopt', so add runtime dependency util-linux-getopt. Install config file and test cases for samba-ctdt-tests at same time. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/samba')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.4.5.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
index a27bcd1e6b..303d5ae2e3 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.4.5.bb
@@ -50,7 +50,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', '${SYSVIN
"
RDEPENDS_${PN}-base += "${@bb.utils.contains('PACKAGECONFIG', 'lsb', 'lsb', '', d)}"
-RDEPENDS_${PN}-ctdb-tests += "bash"
+RDEPENDS_${PN}-ctdb-tests += "bash util-linux-getopt"
PACKAGECONFIG[acl] = "--with-acl-support,--without-acl-support,acl"
PACKAGECONFIG[fam] = "--with-fam,--without-fam,gamin"
@@ -129,6 +129,19 @@ do_install_append() {
install -d ${D}${sysconfdir}/sysconfig/
install -m644 packaging/systemd/samba.sysconfig ${D}${sysconfdir}/sysconfig/samba
+ # install ctdb config file and test cases
+ install -D -m 0644 ${S}/ctdb/tests/onnode/nodes ${D}${sysconfdir}/ctdb/nodes
+ # the items are from ctdb/tests/run_tests.sh
+ for d in onnode takeover tool eventscripts cunit simple complex; do
+ testdir=${D}${datadir}/ctdb-tests/$d
+ install -d $testdir
+ cp ${S}/ctdb/tests/$d/*.sh $testdir
+ cp -r ${S}/ctdb/tests/$d/scripts ${S}/ctdb/tests/$d/stubs $testdir || true
+ done
+
+ # fix file-rdeps qa warning
+ sed -i 's:\(#!/bin/\)bash:\1sh:' ${D}${bindir}/onnode
+
rm -rf ${D}/run ${D}${localstatedir}/run ${D}${localstatedir}/log
}
@@ -147,6 +160,8 @@ FILES_${PN}-base = "${sbindir}/nmbd \
"
FILES_${PN}-ctdb-tests = "${bindir}/ctdb_run_tests \
+ ${bindir}/ctdb_run_cluster_tests \
+ ${sysconfdir}/ctdb/nodes \
${libdir}/ctdb-tests \
${datadir}/ctdb-tests \
/run/ctdb \