aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/samba
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2016-04-29 08:55:21 +0200
committerJoe MacDonald <joe_macdonald@mentor.com>2016-04-29 10:51:41 -0400
commitaa8e156d56d487d5419dd353da50778d56d47703 (patch)
tree21ddcd22bdb235d1da0c28a21e17dcc5c53ca675 /meta-networking/recipes-connectivity/samba
parentffeb84e9ac2fc170b71eb3adcfb54490afed5f53 (diff)
downloadmeta-openembedded-aa8e156d56d487d5419dd353da50778d56d47703.tar.gz
samba: fix paths in sysv initscript
The sysv initscript provided by samba assumes smbd and nmbd are installed in /opt/samba/bin/. In our case both binaries are installed to /usr/sbin/ by default. Therefore fix these paths. Furthermore fix the log and config directory as well as the name of the initscript in its usage text. Signed-off-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/samba')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.4.2.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb b/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb
index 63586ba6c6..383c9c9002 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb
@@ -106,6 +106,11 @@ do_install_append() {
elif ${@bb.utils.contains('PACKAGECONFIG', 'sysv', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/init.d
install -m 0755 packaging/sysv/samba.init ${D}${sysconfdir}/init.d/samba.sh
+ sed -e 's,/opt/samba/bin,${sbindir},g' \
+ -e 's,/opt/samba/smb.conf,${sysconfdir}/samba/smb.conf,g' \
+ -e 's,/opt/samba/log,${localstatedir}/log/samba,g' \
+ -e 's,/etc/init.d/samba.server,${sysconfdir}/init.d/samba.sh,g' \
+ -i ${D}${sysconfdir}/init.d/samba.sh
update-rc.d -r ${D} samba.sh start 20 3 5 .
update-rc.d -r ${D} samba.sh start 20 0 1 6 .
fi