aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2020-02-15 16:59:35 +0100
committerKhem Raj <raj.khem@gmail.com>2020-02-16 12:52:19 -0800
commit2f21a8ce5fdeaf0d8c9c0ae7d2be880be73fc003 (patch)
treeb63af7884fbcf4fa3cc6cf47a17ef8e8b77059f9 /meta-networking/recipes-connectivity
parentc24a06107d739d2496779951eeaca54f2ba9fe68 (diff)
downloadmeta-openembedded-2f21a8ce5fdeaf0d8c9c0ae7d2be880be73fc003.tar.gz
openconnect: use target path to script
openconnect puts the default absolute path to the vpnc-script into its binary from the --with-vpnc-script configure options. So do not prepend the value with the path to the OE sysroot. RDEPEND on vpnc-script to have the script from vpnc installed on target. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb b/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
index 974ff45477..597c1920cf 100644
--- a/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
+++ b/meta-networking/recipes-connectivity/openconnect/openconnect_8.03.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
SRCREV = "ea73851969ae7a6ea54fdd2d2b8c94776af24b2a"
DEPENDS = "vpnc libxml2 krb5 gettext-native"
-RDEPENDS_${PN} = "bash python3-core"
+RDEPENDS_${PN} = "bash python3-core vpnc-script"
PACKAGECONFIG ??= "gnutls lz4 libproxy"
@@ -25,5 +25,5 @@ S = "${WORKDIR}/git"
inherit autotools pkgconfig
-EXTRA_OECONF += "--with-vpnc-script=${SYSROOT_DESTDIR}${sysconfdir}/vpnc/vpnc-script \
+EXTRA_OECONF += "--with-vpnc-script=${sysconfdir}/vpnc/vpnc-script \
--disable-static"