aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
authorKhawaja Shaheryar <behzadshaheryar@gmail.com>2024-02-13 20:13:49 +0500
committerKhem Raj <raj.khem@gmail.com>2024-02-21 19:59:51 -0800
commit26511bb42a0965dbeafd9efc8d00a52e26dc2c11 (patch)
tree3e71e50ed90e3c250c5f33518c823b799d1863d9 /meta-networking/recipes-connectivity
parent7c5f04f8b53c5c991bb7a81667179bb389222309 (diff)
downloadmeta-openembedded-26511bb42a0965dbeafd9efc8d00a52e26dc2c11.tar.gz
libdaq: add recipe
I am adding this recipe as snort3 depends on it. snort3 recipe will be provided in next commit. See more: https://github.com/snort3/libdaq Signed-off-by: Khawaja Shaheryar <behzadshaheryar@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/daq/libdaq/0001-example-Use-lm-for-the-fst-module.patch32
-rw-r--r--meta-networking/recipes-connectivity/daq/libdaq_git.bb18
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/daq/libdaq/0001-example-Use-lm-for-the-fst-module.patch b/meta-networking/recipes-connectivity/daq/libdaq/0001-example-Use-lm-for-the-fst-module.patch
new file mode 100644
index 0000000000..7147c042a1
--- /dev/null
+++ b/meta-networking/recipes-connectivity/daq/libdaq/0001-example-Use-lm-for-the-fst-module.patch
@@ -0,0 +1,32 @@
+From 9357da2a5a829f7a0620e6c19835a65b7b02a8fb Mon Sep 17 00:00:00 2001
+From: Khawaja Shaheryar <behzadshaheryar@gmail.com>
+Date: Tue, 20 Feb 2024 21:03:26 +0500
+Subject: [PATCH] example: Use -lm for the fst module
+
+If -lm is not passed in Makefile.am, the following is seen
+| arm-yoe-linux-gnueabi-ld.lld: error: undefined symbol: ceilf
+| >>> referenced by math.h:632 (/usr/include/c++/v1/math.h:632)
+| >>> libdaq_static_fst_la-daq_fst.o:(std::__1::pair<std::__1::__hash_iterator<std::__1::__hash_node<std::__1::__hash_value_type<FstKey, FstNode*>, void*>*>, bool> std::__1::__hash_table<std::__1::__hash_value_type<FstKey, FstNode*>, std::__1::__unordered_map_hasher<FstKey, std::__1::__hash_value_type<FstKey, FstNode*>, FstKeyHash, std::__1::equal_to<FstKey>, true>, std::__1::__unordered_map_equal<FstKey, std::__1::__hash_value_type<FstKey, FstNode*>, std::__1::equal_to<FstKey>, FstKeyHash, true>, std::__1::allocator<std::__1::__hash_value_type<FstKey, FstNode*>>>::__emplace_unique_key_args<FstKey, std::__1::pair<FstKey const, FstNode*>>(FstKey const&, std::__1::pair<FstKey const, FstNode*>&&)) in archive ../modules/fst/.libs/libdaq_static_fst.a
+
+Upstream-Status: Pending
+
+Signed-off-by: Khawaja Shaheryar <behzadshaheryar@gmail.com>
+---
+ example/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/example/Makefile.am b/example/Makefile.am
+index 0d5ca31..1eaa9e8 100644
+--- a/example/Makefile.am
++++ b/example/Makefile.am
+@@ -31,6 +31,7 @@ endif
+ if BUILD_FST_MODULE
+ daqtest_static_CFLAGS += -DBUILD_FST_MODULE
+ daqtest_static_LDADD += ${top_builddir}/modules/fst/libdaq_static_fst.la $(DAQ_FST_LIBS)
++daqtest_static_LDFLAGS += -lm
+ endif
+ if BUILD_NETMAP_MODULE
+ daqtest_static_CFLAGS += -DBUILD_NETMAP_MODULE
+--
+2.34.1
+
diff --git a/meta-networking/recipes-connectivity/daq/libdaq_git.bb b/meta-networking/recipes-connectivity/daq/libdaq_git.bb
new file mode 100644
index 0000000000..19346124bf
--- /dev/null
+++ b/meta-networking/recipes-connectivity/daq/libdaq_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "LibDAQ: The Data AcQuisition Library"
+DESCRIPTION = "LibDAQ is a pluggable abstraction layer for interacting with a data source (traditionally a network interface or network data plane)."
+HOMEPAGE = "http://www.snort.org"
+SECTION = "libs"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=79258250506422d064560a7b95b2d53e"
+
+DEPENDS = "libdnet libpcap"
+
+inherit autotools pkgconfig
+
+SRC_URI = "git://github.com/snort3/libdaq.git;protocol=https;branch=master \
+ file://0001-example-Use-lm-for-the-fst-module.patch"
+SRCREV = "c757aaae5a70d5bbb3239c5a16bca217a5aca651"
+
+S = "${WORKDIR}/git"
+
+FILES:${PN} += "${libdir}/daq/*.so"