aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/proftpd
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2016-08-12 15:19:56 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-16 21:26:11 -0400
commit1ea6e9a5d2d50ad3184326fb1631a8b9e3f1018c (patch)
treeec007c9d1cac5e1959b47098c3a0be091c2a672e /meta-networking/recipes-daemons/proftpd
parent4307c6a746ef25540c84446c821658062a89bb15 (diff)
downloadmeta-openembedded-1ea6e9a5d2d50ad3184326fb1631a8b9e3f1018c.tar.gz
proftpd: fix system account login failure
When pam is enabled, 1, Customize the proftpd.conf to use pam to authenticate 2, Add proftpd pam configuration file /etc/pam.d/proftpd Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-daemons/proftpd')
-rw-r--r--meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
index b6fd4b2e11..2332ef856d 100644
--- a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
+++ b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.5a.bb
@@ -92,6 +92,15 @@ do_install () {
# create the pub directory
mkdir -p ${D}/home/${FTPUSER}/pub/
chown -R ${FTPUSER}:${FTPGROUP} ${D}/home/${FTPUSER}/pub
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'true', 'false', d)}; then
+ # install proftpd pam configuration
+ install -d ${D}${sysconfdir}/pam.d
+ install -m 644 ${S}/contrib/dist/rpm/ftp.pamd ${D}${sysconfdir}/pam.d/proftpd
+ sed -i '/ftpusers/d' ${D}${sysconfdir}/pam.d/proftpd
+ # specify the user Authentication config
+ sed -i '/^MaxInstances/a\AuthPAM on\nAuthPAMConfig proftpd' \
+ ${D}${sysconfdir}/proftpd.conf
+ fi
install -d ${D}/${systemd_unitdir}/system
install -m 644 ${WORKDIR}/proftpd.service ${D}/${systemd_unitdir}/system