aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 13:37:43 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:03 +0200
commit9858cfdb4868ba7ed90d8e46784b7723c30e12c1 (patch)
treeb650fd7916b5a34f9a2839ef052581d68d6d7c8c /meta-networking/recipes-daemons
parent05fbf945581f512815abd8d0804ccffacbecff7b (diff)
downloadmeta-openembedded-9858cfdb4868ba7ed90d8e46784b7723c30e12c1.tar.gz
autofs: move systemd support from meta-systemd back to meta-networking
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
index 6751402bbb..8db4378d39 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.0.7.bb
@@ -3,11 +3,11 @@ SECTION = "base"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-PR = "r3"
+PR = "r6"
DEPENDS += "libtirpc flex-native bison-native"
-inherit autotools
+inherit autotools systemd
SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.bz2 \
file://autofs-5.0.7-fix-nobind-sun-escaped-map-entries.patch \
@@ -97,3 +97,8 @@ do_install_append () {
}
INSANE_SKIP_${PN} = "dev-so"
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "autofs.service"