aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-networking/recipes-daemons
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r--meta-networking/recipes-daemons/atftp/atftp_0.7.4.bb18
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb14
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.27.bb22
-rw-r--r--meta-networking/recipes-daemons/ippool/ippool_1.3.bb14
-rw-r--r--meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.4.bb4
-rw-r--r--meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb6
-rw-r--r--meta-networking/recipes-daemons/lldpd/lldpd_1.0.8.bb14
-rw-r--r--meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb2
-rw-r--r--meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.1.bb4
-rw-r--r--meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb10
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb20
-rw-r--r--meta-networking/recipes-daemons/postfix/postfix.inc40
-rw-r--r--meta-networking/recipes-daemons/proftpd/proftpd_1.3.7a.bb10
-rw-r--r--meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb2
-rw-r--r--meta-networking/recipes-daemons/radvd/radvd.inc8
-rw-r--r--meta-networking/recipes-daemons/squid/squid_4.15.bb26
-rw-r--r--meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb16
-rw-r--r--meta-networking/recipes-daemons/vblade/vblade_25.bb2
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb20
19 files changed, 126 insertions, 126 deletions
diff --git a/meta-networking/recipes-daemons/atftp/atftp_0.7.4.bb b/meta-networking/recipes-daemons/atftp/atftp_0.7.4.bb
index 936fc723f7..7661e9c48e 100644
--- a/meta-networking/recipes-daemons/atftp/atftp_0.7.4.bb
+++ b/meta-networking/recipes-daemons/atftp/atftp_0.7.4.bb
@@ -21,13 +21,13 @@ PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
PACKAGECONFIG[readline] = "--enable-libreadline,--disable-libreadline,readline"
INITSCRIPT_PACKAGES = "${PN}d"
-INITSCRIPT_NAME_${PN}d = "atftpd"
-INITSCRIPT_PARAMS_${PN}d = "defaults 80"
+INITSCRIPT_NAME:${PN}d = "atftpd"
+INITSCRIPT_PARAMS:${PN}d = "defaults 80"
EXTRA_OEMAKE = "CFLAGS='${CFLAGS} -std=gnu89'"
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/atftpd.init ${D}${sysconfdir}/init.d/atftpd
@@ -41,16 +41,16 @@ do_install_append() {
PACKAGES =+ "${PN}d"
-FILES_${PN} = "${bindir}/*"
+FILES:${PN} = "${bindir}/*"
-FILES_${PN}d = "${sbindir}/* \
+FILES:${PN}d = "${sbindir}/* \
${sysconfdir} \
/srv/tftp \
${systemd_unitdir}/system/atftpd.service \
"
SYSTEMD_PACKAGES = "${PN}d"
-SYSTEMD_SERVICE_${PN}d = "atftpd.service"
-RPROVIDES_${PN}d += "${PN}d-systemd"
-RREPLACES_${PN}d += "${PN}d-systemd"
-RCONFLICTS_${PN}d += "${PN}d-systemd"
+SYSTEMD_SERVICE:${PN}d = "atftpd.service"
+RPROVIDES:${PN}d += "${PN}d-systemd"
+RREPLACES:${PN}d += "${PN}d-systemd"
+RCONFLICTS:${PN}d += "${PN}d-systemd"
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb
index fd49e53bbd..3fc574fd0a 100644
--- a/meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.7.bb
@@ -60,14 +60,14 @@ CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
piddir=/run \
"
-do_configure_prepend () {
+do_configure:prepend () {
if [ ! -e ${S}/acinclude.m4 ]; then
cp ${S}/aclocal.m4 ${S}/acinclude.m4
fi
cp ${STAGING_DATADIR_NATIVE}/aclocal/pkg.m4 .
}
-do_install_append () {
+do_install:append () {
# samples have been removed from SUBDIRS from 5.1.5, need to install separately
oe_runmake 'DESTDIR=${D}' install_samples
@@ -90,9 +90,9 @@ SOLIBS = ".so"
FILES_SOLIBSDEV = ""
# Some symlinks are created in plugins dir e.g.
# mount_nfs4.so -> mount_nfs.so
-INSANE_SKIP_${PN} = "dev-so"
+INSANE_SKIP:${PN} = "dev-so"
-RPROVIDES_${PN} += "${PN}-systemd"
-RREPLACES_${PN} += "${PN}-systemd"
-RCONFLICTS_${PN} += "${PN}-systemd"
-SYSTEMD_SERVICE_${PN} = "autofs.service"
+RPROVIDES:${PN} += "${PN}-systemd"
+RREPLACES:${PN} += "${PN}-systemd"
+RCONFLICTS:${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE:${PN} = "autofs.service"
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.27.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.27.bb
index c4b41ace8c..46aeb23a3b 100644
--- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.27.bb
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.27.bb
@@ -41,7 +41,7 @@ PACKAGECONFIG[ntlm] = "--enable-ntlm=yes,--enable-ntlm=no,,"
CFLAGS += "-fPIC"
-do_configure_prepend () {
+do_configure:prepend () {
# make it be able to work with db 5.0 version
local sed_files="sasldb/db_berkeley.c utils/dbconverter-2.c"
for sed_file in $sed_files; do
@@ -49,14 +49,14 @@ do_configure_prepend () {
done
}
-do_compile_prepend () {
+do_compile:prepend () {
cd include
${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} ${S}/include/makemd5.c -o makemd5
touch makemd5.o makemd5.lo makemd5
cd ..
}
-do_install_append() {
+do_install:append() {
if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/saslauthd.service ${D}${systemd_unitdir}/system
@@ -75,10 +75,10 @@ do_install_append() {
}
USERADD_PACKAGES = "${PN}-bin"
-USERADD_PARAM_${PN}-bin = "--system --home=/var/spool/mail -g mail cyrus"
+USERADD_PARAM:${PN}-bin = "--system --home=/var/spool/mail -g mail cyrus"
SYSTEMD_PACKAGES = "${PN}-bin"
-SYSTEMD_SERVICE_${PN}-bin = "saslauthd.service"
+SYSTEMD_SERVICE:${PN}-bin = "saslauthd.service"
SYSTEMD_AUTO_ENABLE = "disable"
SRC_URI[md5sum] = "a7f4e5e559a0e37b3ffc438c9456e425"
@@ -86,16 +86,16 @@ SRC_URI[sha256sum] = "8fbc5136512b59bb793657f36fadda6359cae3b08f01fd16b3d406f134
PACKAGES =+ "${PN}-bin"
-FILES_${PN} += "${libdir}/sasl2/*.so*"
-FILES_${PN}-bin += "${bindir} \
+FILES:${PN} += "${libdir}/sasl2/*.so*"
+FILES:${PN}-bin += "${bindir} \
${sysconfdir}/default/saslauthd \
${systemd_unitdir}/system/saslauthd.service \
${sysconfdir}/tmpfiles.d/saslauthd.conf"
-FILES_${PN}-dev += "${libdir}/sasl2/*.la"
-FILES_${PN}-dbg += "${libdir}/sasl2/.debug"
-FILES_${PN}-staticdev += "${libdir}/sasl2/*.a"
+FILES:${PN}-dev += "${libdir}/sasl2/*.la"
+FILES:${PN}-dbg += "${libdir}/sasl2/.debug"
+FILES:${PN}-staticdev += "${libdir}/sasl2/*.a"
-INSANE_SKIP_${PN} += "dev-so"
+INSANE_SKIP:${PN} += "dev-so"
# CVE-2020-8032 affects only openSUSE
CVE_CHECK_WHITELIST += "CVE-2020-8032"
diff --git a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
index 3554e688ab..19fbd0fa24 100644
--- a/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
+++ b/meta-networking/recipes-daemons/ippool/ippool_1.3.bb
@@ -36,7 +36,7 @@ SRC_URI[sha256sum] = "d3eab7d6cad5da8ccc9d1e31d5303e27a39622c07bdb8fa3618eea3144
inherit systemd
DEPENDS = "readline ppp ncurses gzip-native rpcsvc-proto-native libtirpc"
-RDEPENDS_${PN} = "rpcbind"
+RDEPENDS:${PN} = "rpcbind"
EXTRA_OEMAKE = "CC='${CC}' AS='${AS}' LD='${LD}' AR='${AR}' NM='${NM}' STRIP='${STRIP}'"
EXTRA_OEMAKE += "PPPD_VERSION=${PPPD_VERSION} SYS_LIBDIR=${libdir}"
@@ -45,11 +45,11 @@ EXTRA_OEMAKE += "IPPOOL_TEST=y"
CPPFLAGS += "${SELECTED_OPTIMIZATION} -I${STAGING_INCDIR}/tirpc"
-SYSTEMD_SERVICE_${PN} = "ippool.service"
+SYSTEMD_SERVICE:${PN} = "ippool.service"
SYSTEMD_AUTO_ENABLE = "disable"
-do_compile_prepend() {
+do_compile:prepend() {
# fix the CFLAGS= and CPPFLAGS= in main Makefile, to have the extra CFLAGS in env
sed -i -e "s/^CFLAGS=/CFLAGS+=/" ${S}/Makefile
sed -i -e "s/^CPPFLAGS=/CPPFLAGS+=/" ${S}/Makefile
@@ -79,12 +79,12 @@ do_install() {
PACKAGES =+ "${PN}-test"
-FILES_${PN} += "${libdir}/pppd/${PPPD_VERSION}/ippool.so"
-FILES_${PN}-dbg += "${libdir}/pppd/${PPPD_VERSION}/.debug/ippool.so"
-FILES_${PN}-test = "/opt/${BPN}"
+FILES:${PN} += "${libdir}/pppd/${PPPD_VERSION}/ippool.so"
+FILES:${PN}-dbg += "${libdir}/pppd/${PPPD_VERSION}/.debug/ippool.so"
+FILES:${PN}-test = "/opt/${BPN}"
# needs tcl to run tests
-RDEPENDS_${PN}-test += "tcl ${BPN}"
+RDEPENDS:${PN}-test += "tcl ${BPN}"
PPPD_VERSION="${@get_ppp_version(d)}"
diff --git a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.4.bb b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.4.bb
index 8a3dd011e4..8e0da23b68 100644
--- a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.4.bb
+++ b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.4.bb
@@ -100,7 +100,7 @@ do_install () {
fi
}
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
if [ "x$D" = "x" ]; then
if [ -e /etc/init.d/populate-volatile.sh ]; then
/etc/init.d/populate-volatile.sh update
@@ -114,4 +114,4 @@ SYSTEMD_SERVICE = " iscsi-initiator.service iscsi-initiator-targets.service "
INITSCRIPT_NAME = "iscsid"
INITSCRIPT_PARAMS = "start 30 1 2 3 4 5 . stop 70 0 1 2 3 4 5 6 ."
-FILES_${PN} += "${nonarch_libdir}/iscsi"
+FILES:${PN} += "${nonarch_libdir}/iscsi"
diff --git a/meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb b/meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb
index f0cbca1bec..d04b73876d 100644
--- a/meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb
+++ b/meta-networking/recipes-daemons/keepalived/keepalived_2.2.2.bb
@@ -29,7 +29,7 @@ PACKAGECONFIG[systemd] = "--with-init=systemd --with-systemdsystemunitdir=${syst
EXTRA_OEMAKE = "initdir=${sysconfdir}/init.d"
-do_install_append() {
+do_install:append() {
if [ -f ${D}${sysconfdir}/init.d/${BPN} ]; then
chmod 0755 ${D}${sysconfdir}/init.d/${BPN}
sed -i 's#rc.d/##' ${D}${sysconfdir}/init.d/${BPN}
@@ -40,7 +40,7 @@ do_install_append() {
fi
}
-FILES_${PN} += "${datadir}/snmp/mibs/KEEPALIVED-MIB.txt"
+FILES:${PN} += "${datadir}/snmp/mibs/KEEPALIVED-MIB.txt"
-SYSTEMD_SERVICE_${PN} = "keepalived.service"
+SYSTEMD_SERVICE:${PN} = "keepalived.service"
SYSTEMD_AUTO_ENABLE ?= "disable"
diff --git a/meta-networking/recipes-daemons/lldpd/lldpd_1.0.8.bb b/meta-networking/recipes-daemons/lldpd/lldpd_1.0.8.bb
index bd94c09198..d5e9e2c303 100644
--- a/meta-networking/recipes-daemons/lldpd/lldpd_1.0.8.bb
+++ b/meta-networking/recipes-daemons/lldpd/lldpd_1.0.8.bb
@@ -17,8 +17,8 @@ SRC_URI[sha256sum] = "98d200e76e30f6262c4a4493148c1840827898329146a57a34f8f0f928
inherit autotools update-rc.d useradd systemd pkgconfig bash-completion
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system -g lldpd --shell /bin/false lldpd"
-GROUPADD_PARAM_${PN} = "--system lldpd"
+USERADD_PARAM:${PN} = "--system -g lldpd --shell /bin/false lldpd"
+GROUPADD_PARAM:${PN} = "--system lldpd"
EXTRA_OECONF += "--without-embedded-libevent \
--disable-oldies \
@@ -45,9 +45,9 @@ PACKAGECONFIG[custom] = "--enable-custom,--disable-custom"
INITSCRIPT_NAME = "lldpd"
INITSCRIPT_PARAMS = "defaults"
-SYSTEMD_SERVICE_${PN} = "lldpd.service"
+SYSTEMD_SERVICE:${PN} = "lldpd.service"
-do_install_append() {
+do_install:append() {
install -Dm 0755 ${WORKDIR}/lldpd.init.d ${D}${sysconfdir}/init.d/lldpd
install -Dm 0644 ${WORKDIR}/lldpd.default ${D}${sysconfdir}/default/lldpd
# Make an empty configuration file
@@ -56,9 +56,9 @@ do_install_append() {
PACKAGES =+ "${PN}-zsh-completion"
-FILES_${PN} += "${libdir}/sysusers.d"
-RDEPENDS_${PN} += "os-release"
+FILES:${PN} += "${libdir}/sysusers.d"
+RDEPENDS:${PN} += "os-release"
-FILES_${PN}-zsh-completion += "${datadir}/zsh/"
+FILES:${PN}-zsh-completion += "${datadir}/zsh/"
# FIXME: zsh is broken in meta-oe so this cannot be enabled for now
#RDEPENDS_${PN}-zsh-completion += "zsh"
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb
index ee6da5737f..592f98f9d3 100644
--- a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb
+++ b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb
@@ -21,7 +21,7 @@ PACKAGECONFIG ??= ""
PACKAGECONFIG[ccdv] = "--enable-ccdv,--disable-ccdv,,"
EXTRA_OECONF = "--disable-precomp"
-TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"
+TARGET_CC_ARCH:append = " ${SELECTED_OPTIMIZATION}"
do_configure() {
install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
diff --git a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.1.bb b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.1.bb
index a697e983f6..5159cf51e4 100644
--- a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.1.bb
+++ b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.1.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
inherit features_check systemd
-RDEPENDS_${PN} = "python3-pygobject python3-dbus"
+RDEPENDS:${PN} = "python3-pygobject python3-dbus"
REQUIRED_DISTRO_FEATURES = "systemd"
SRCREV = "30e278e50749a60a930ceaa0971207c6436b8a0c"
@@ -18,7 +18,7 @@ SRC_URI = "git://gitlab.com/craftyguy/networkd-dispatcher;protocol=https;nobranc
S = "${WORKDIR}/git"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "networkd-dispatcher.service"
+SYSTEMD_SERVICE:${PN} = "networkd-dispatcher.service"
SYSTEMD_AUTO_ENABLE = "disable"
# Nothing to build, just a python script to install
diff --git a/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb b/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb
index e8d19a2c0b..bacf984e74 100644
--- a/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb
+++ b/meta-networking/recipes-daemons/openhpi/openhpi_3.8.0.bb
@@ -55,10 +55,10 @@ inherit autotools pkgconfig ptest update-rc.d systemd
PACKAGES =+ "${PN}-libs"
-FILES_${PN}-libs = "${libdir}/${BPN}/*.so /usr/lib/${BPN}/*.so"
+FILES:${PN}-libs = "${libdir}/${BPN}/*.so /usr/lib/${BPN}/*.so"
-INSANE_SKIP_${PN}-libs = "dev-so"
-RDEPENDS_${PN} += "${PN}-libs"
+INSANE_SKIP:${PN}-libs = "dev-so"
+RDEPENDS:${PN} += "${PN}-libs"
PACKAGECONFIG ??= "libgcrypt non32bit snmp-bc"
PACKAGECONFIG[sysfs] = "--enable-sysfs,--disable-sysfs,sysfsutils,"
@@ -68,7 +68,7 @@ PACKAGECONFIG[snmp-bc] = "--enable-snmp_bc,--disable-snmp_bc"
export DISTRO
-do_install_append () {
+do_install:append () {
install -m 0755 -d ${D}${sysconfdir}/${BPN}
install -m 0644 ${S}/openhpiclient.conf.example ${D}${sysconfdir}/${BPN}/openhpiclient.conf
install -m 0600 ${S}/openhpi.conf.example ${D}${sysconfdir}/${BPN}/openhpi.conf
@@ -134,5 +134,5 @@ do_install_ptest () {
INITSCRIPT_NAME = "openhpid"
INITSCRIPT_PARAMS = "start 30 . stop 70 0 1 2 3 4 5 6 ."
-SYSTEMD_SERVICE_${PN} = "openhpid.service"
+SYSTEMD_SERVICE:${PN} = "openhpid.service"
SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb
index a971677203..caa85e040a 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.21.06.bb
@@ -37,10 +37,10 @@ UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/opensaf/files/releases"
inherit autotools useradd systemd pkgconfig
USERADD_PACKAGES = "${PN}"
-GROUPADD_PARAM_${PN} = "-f -r opensaf"
-USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
+GROUPADD_PARAM:${PN} = "-f -r opensaf"
+USERADD_PARAM:${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
-SYSTEMD_SERVICE_${PN} += "opensafd.service"
+SYSTEMD_SERVICE:${PN} += "opensafd.service"
SYSTEMD_AUTO_ENABLE = "disable"
PACKAGECONFIG[systemd] = ",,systemd"
@@ -53,7 +53,7 @@ CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation"
CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation="
LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
-do_install_append() {
+do_install:append() {
rm -fr "${D}${localstatedir}/lock"
rm -fr "${D}${localstatedir}/run"
rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
@@ -64,15 +64,15 @@ do_install_append() {
fi
}
-FILES_${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service"
-FILES_${PN}-dev += "${libdir}/libopensaf_core.so"
-FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
+FILES:${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service"
+FILES:${PN}-dev += "${libdir}/libopensaf_core.so"
+FILES:${PN}-staticdev += "${PKGLIBDIR}/*.a"
-INSANE_SKIP_${PN} = "dev-so"
+INSANE_SKIP:${PN} = "dev-so"
-RDEPENDS_${PN} += "bash python3-core"
+RDEPENDS:${PN} += "bash python3-core"
# http://errors.yoctoproject.org/Errors/Details/186970/
-COMPATIBLE_HOST_libc-musl = 'null'
+COMPATIBLE_HOST:libc-musl = 'null'
FILES_SOLIBSDEV = ""
diff --git a/meta-networking/recipes-daemons/postfix/postfix.inc b/meta-networking/recipes-daemons/postfix/postfix.inc
index 4b9940cc7a..7bf258374c 100644
--- a/meta-networking/recipes-daemons/postfix/postfix.inc
+++ b/meta-networking/recipes-daemons/postfix/postfix.inc
@@ -25,11 +25,11 @@ inherit update-rc.d useradd update-alternatives systemd lib_package
INITSCRIPT_NAME = "postfix"
INITSCRIPT_PARAMS = "start 58 3 4 5 . stop 13 0 1 6 ."
USERADD_PACKAGES = "${PN}-bin"
-USERADD_PARAM_${PN}-bin = \
+USERADD_PARAM:${PN}-bin = \
"-d /var/spool/postfix -r -g postfix --shell /bin/false postfix; \
-d /var/spool/vmail -r -g vmail --shell /bin/false vmail \
"
-GROUPADD_PARAM_${PN}-bin = "--system postfix;--system postdrop;--system vmail"
+GROUPADD_PARAM:${PN}-bin = "--system postfix;--system postdrop;--system vmail"
export SYSLIBS = "${LDFLAGS}"
@@ -45,10 +45,10 @@ export AUXLIBS-ldap = "\
${@bb.utils.contains('DISTRO_FEATURES', 'ldap', '-lldap -llber', '', d)}"
# no native openldap
-export CCARGS-ldap_class-native = ""
-export AUXLIBS-ldap_class-native = ""
+export CCARGS-ldap:class-native = ""
+export AUXLIBS-ldap:class-native = ""
-export CCARGS-nonis_libc-musl = "-DNO_NIS"
+export CCARGS-nonis:libc-musl = "-DNO_NIS"
export CCARGS-nonis = ""
# SASL support -DUSE_LDAP_SASL -DUSE_SASL_AUTH
@@ -57,8 +57,8 @@ export CCARGS-sasl = "\
${@bb.utils.contains('DISTRO_FEATURES', 'sasl', '-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I${STAGING_INCDIR}/sasl', '', d)}"
export AUXLIBS-sasl = "\
${@bb.utils.contains('DISTRO_FEATURES', 'sasl', '-lsasl2', '', d)}"
-export CCARGS-sasl_class-native = ""
-export AUXLIBS-sasl_class-native = ""
+export CCARGS-sasl:class-native = ""
+export AUXLIBS-sasl:class-native = ""
# PCRE, TLS support default
export CCARGS = "${CFLAGS} -DHAS_PCRE -DUSE_TLS -I${STAGING_INCDIR}/openssl ${CCARGS-ldap} ${CCARGS-sasl} ${CCARGS-nonis}"
@@ -95,11 +95,11 @@ do_compile () {
oe_runmake
}
-do_install_prepend_class-native() {
+do_install:prepend:class-native() {
export POSTCONF="bin/postconf"
}
-SYSTEMD_SERVICE_${PN} = "postfix.service"
+SYSTEMD_SERVICE:${PN} = "postfix.service"
do_install () {
sh ./postfix-install 'install_root=${D}' \
@@ -180,14 +180,14 @@ do_install () {
rm -rf ${D}/etc/postfix/makedefs.out
}
-do_install_append_class-native() {
+do_install:append:class-native() {
ln -sf ../sbin/sendmail.postfix ${D}${bindir}/newaliases
ln -sf ../sbin/sendmail.postfix ${D}${bindir}/mailq
}
-ALTERNATIVE_${PN}-bin = "sendmail mailq newaliases"
+ALTERNATIVE:${PN}-bin = "sendmail mailq newaliases"
# /usr/lib/sendmial is required by LSB core test
-ALTERNATIVE_${PN}-bin_linuxstdbase = "sendmail mailq newaliases usr-lib-sendmail"
+ALTERNATIVE:${PN}-bin:linuxstdbase = "sendmail mailq newaliases usr-lib-sendmail"
ALTERNATIVE_TARGET[mailq] = "${bindir}/mailq"
ALTERNATIVE_TARGET[newaliases] = "${bindir}/newaliases"
ALTERNATIVE_TARGET[sendmail] = "${sbindir}/sendmail.postfix"
@@ -197,12 +197,12 @@ ALTERNATIVE_LINK_NAME[usr-lib-sendmail] = "/usr/lib/sendmail"
ALTERNATIVE_PRIORITY = "120"
-ALTERNATIVE_${PN}-doc += "mailq.1 newaliases.1 sendmail.1"
+ALTERNATIVE:${PN}-doc += "mailq.1 newaliases.1 sendmail.1"
ALTERNATIVE_LINK_NAME[mailq.1] = "${mandir}/man1/mailq.1"
ALTERNATIVE_LINK_NAME[newaliases.1] = "${mandir}/man1/newaliases.1"
ALTERNATIVE_LINK_NAME[sendmail.1] = "${mandir}/man1/sendmail.1"
-pkg_postinst_ontarget_${PN}-cfg () {
+pkg_postinst_ontarget:${PN}-cfg () {
touch /etc/aliases
newaliases
@@ -212,11 +212,11 @@ pkg_postinst_ontarget_${PN}-cfg () {
}
PACKAGES =+ "${PN}-cfg"
-RDEPENDS_${PN}-cfg_class-target += "${PN}-bin"
-RDEPENDS_${PN}_class-target += "${PN}-cfg"
+RDEPENDS:${PN}-cfg:class-target += "${PN}-bin"
+RDEPENDS:${PN}:class-target += "${PN}-cfg"
# Exclude .debug directories from the main package
-FILES_${PN}-bin += "${localstatedir} ${bindir}/* ${sbindir}/* \
+FILES:${PN}-bin += "${localstatedir} ${bindir}/* ${sbindir}/* \
${libexecdir}/* ${systemd_unitdir}/*"
-FILES_${PN}-cfg = "${sysconfdir}"
-FILES_${PN}-dbg += "${libexecdir}/postfix/.debug"
-ALLOW_EMPTY_${PN} = "1"
+FILES:${PN}-cfg = "${sysconfdir}"
+FILES:${PN}-dbg += "${libexecdir}/postfix/.debug"
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.7a.bb b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.7a.bb
index f2a89e5a2f..981757b563 100644
--- a/meta-networking/recipes-daemons/proftpd/proftpd_1.3.7a.bb
+++ b/meta-networking/recipes-daemons/proftpd/proftpd_1.3.7a.bb
@@ -131,15 +131,15 @@ INITSCRIPT_NAME = "proftpd"
INITSCRIPT_PARAM = "defaults 85 15"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "proftpd.service"
+SYSTEMD_SERVICE:${PN} = "proftpd.service"
USERADD_PACKAGES = "${PN}"
-GROUPADD_PARAM_${PN} = "--system ${FTPGROUP}"
-USERADD_PARAM_${PN} = "--system -g ${FTPGROUP} --home-dir /var/lib/${FTPUSER} --no-create-home \
+GROUPADD_PARAM:${PN} = "--system ${FTPGROUP}"
+USERADD_PARAM:${PN} = "--system -g ${FTPGROUP} --home-dir /var/lib/${FTPUSER} --no-create-home \
--shell /bin/false ${FTPUSER}"
MULTILIB_SCRIPTS = "${PN}:${bindir}/prxs"
-FILES_${PN} += "/home/${FTPUSER}"
+FILES:${PN} += "/home/${FTPUSER}"
-RDEPENDS_${PN} += "perl"
+RDEPENDS:${PN} += "perl"
diff --git a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb
index 227c9f9170..d1eb6e28fc 100644
--- a/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb
+++ b/meta-networking/recipes-daemons/ptpd/ptpd_2.3.1.bb
@@ -58,5 +58,5 @@ do_install() {
}
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "ptpd.service"
+SYSTEMD_SERVICE:${PN} = "ptpd.service"
SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-networking/recipes-daemons/radvd/radvd.inc b/meta-networking/recipes-daemons/radvd/radvd.inc
index 802dbe34e9..2afaa48411 100644
--- a/meta-networking/recipes-daemons/radvd/radvd.inc
+++ b/meta-networking/recipes-daemons/radvd/radvd.inc
@@ -23,10 +23,10 @@ SRC_URI = "http://v6web.litech.org/radvd/dist/radvd-${PV}.tar.gz \
inherit autotools useradd pkgconfig systemd
-SYSTEMD_SERVICE_${PN} = "radvd.service"
+SYSTEMD_SERVICE:${PN} = "radvd.service"
SYSTEMD_AUTO_ENABLE = "disable"
-do_install_append () {
+do_install:append () {
install -m 0755 -d ${D}${sysconfdir}/init.d \
${D}${sysconfdir}/default/volatiles \
${D}${docdir}/radvd
@@ -58,9 +58,9 @@ do_install_append () {
}
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --home ${localstatedir}/run/radvd/ -M -g nogroup radvd"
+USERADD_PARAM:${PN} = "--system --home ${localstatedir}/run/radvd/ -M -g nogroup radvd"
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
if [ -z "$D" -a -x /etc/init.d/populate-volatile.sh ]; then
/etc/init.d/populate-volatile.sh update
fi
diff --git a/meta-networking/recipes-daemons/squid/squid_4.15.bb b/meta-networking/recipes-daemons/squid/squid_4.15.bb
index 8ba10674c9..5af00d6269 100644
--- a/meta-networking/recipes-daemons/squid/squid_4.15.bb
+++ b/meta-networking/recipes-daemons/squid/squid_4.15.bb
@@ -27,7 +27,7 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${BPN}-${PV}.tar.bz2
file://0001-Fix-build-on-Fedora-Rawhide-772.patch \
"
-SRC_URI_remove_toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch"
+SRC_URI:remove:toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch"
SRC_URI[sha256sum] = "71635811e766ce8b155225a9e3c7757cfc7ff93df26b28d82e5e6fc021b9a605"
@@ -38,13 +38,13 @@ DEPENDS = "libtool krb5 openldap db cyrus-sasl"
inherit autotools pkgconfig useradd ptest perlnative
-LDFLAGS_append_mipsarch = " -latomic"
-LDFLAGS_append_powerpc = " -latomic"
-LDFLAGS_append_riscv64 = " -latomic"
-LDFLAGS_append_riscv32 = " -latomic"
+LDFLAGS:append:mipsarch = " -latomic"
+LDFLAGS:append:powerpc = " -latomic"
+LDFLAGS:append:riscv64 = " -latomic"
+LDFLAGS:append:riscv32 = " -latomic"
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --no-create-home --home-dir /var/run/squid --shell /bin/false --user-group squid"
+USERADD_PARAM:${PN} = "--system --no-create-home --home-dir /var/run/squid --shell /bin/false --user-group squid"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
"
@@ -68,7 +68,7 @@ export BUILDCXXFLAGS="${BUILD_CXXFLAGS}"
TESTDIR = "test-suite"
-do_configure_prepend() {
+do_configure:prepend() {
export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
}
@@ -92,7 +92,7 @@ do_install_ptest() {
sed -i 's:^TRUE = .*$:TRUE = /bin/true:' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
}
-do_install_append() {
+do_install:append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/tmpfiles.d
echo "d ${localstatedir}/run/${BPN} 0755 squid squid -" >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
@@ -109,9 +109,9 @@ do_install_append() {
rmdir --ignore-fail-on-non-empty "${D}${localstatedir}/log"
}
-FILES_${PN} += "${libdir} ${datadir}/errors ${datadir}/icons"
-FILES_${PN}-dbg += "/usr/src/debug"
-FILES_${PN}-doc += "${datadir}/*.txt"
+FILES:${PN} += "${libdir} ${datadir}/errors ${datadir}/icons"
+FILES:${PN}-dbg += "/usr/src/debug"
+FILES:${PN}-doc += "${datadir}/*.txt"
-RDEPENDS_${PN} += "perl"
-RDEPENDS_${PN}-ptest += "make"
+RDEPENDS:${PN} += "perl"
+RDEPENDS:${PN}-ptest += "make"
diff --git a/meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb b/meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb
index dc1d6c67ef..af42bda93c 100644
--- a/meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb
+++ b/meta-networking/recipes-daemons/tftp-hpa/tftp-hpa_5.2.bb
@@ -72,26 +72,26 @@ do_install() {
sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tftpd-hpa.service
}
-FILES_${PN} = "${bindir}"
+FILES:${PN} = "${bindir}"
PACKAGES += "tftp-hpa-server"
-SUMMARY_tftp-hpa-server = "Server for the Trivial File Transfer Protocol"
-FILES_tftp-hpa-server = "${sbindir} ${sysconfdir} ${localstatedir}"
-CONFFILES_tftp-hpa-server = "${sysconfdir}/default/tftpd-hpa"
+SUMMARY:tftp-hpa-server = "Server for the Trivial File Transfer Protocol"
+FILES:tftp-hpa-server = "${sbindir} ${sysconfdir} ${localstatedir}"
+CONFFILES:tftp-hpa-server = "${sysconfdir}/default/tftpd-hpa"
INITSCRIPT_PACKAGES = "tftp-hpa-server"
INITSCRIPT_NAME = "tftpd-hpa"
INITSCRIPT_PARAMS = "start 20 2 3 4 5 . stop 20 1 ."
-ALTERNATIVE_${PN}-doc = "tftpd.8 tftp.1"
+ALTERNATIVE:${PN}-doc = "tftpd.8 tftp.1"
ALTERNATIVE_LINK_NAME[tftpd.8] = "${mandir}/man8/tftpd.8"
ALTERNATIVE_LINK_NAME[tftp.1] = "${mandir}/man1/tftp.1"
-ALTERNATIVE_${PN} = "tftp"
+ALTERNATIVE:${PN} = "tftp"
ALTERNATIVE_TARGET[tftp] = "${bindir}/tftp-hpa"
ALTERNATIVE_PRIORITY = "100"
SYSTEMD_PACKAGES = "tftp-hpa-server"
-SYSTEMD_SERVICE_tftp-hpa-server = "tftpd-hpa.socket tftpd-hpa.service"
-SYSTEMD_AUTO_ENABLE_tftp-hpa-server = "enable"
+SYSTEMD_SERVICE:tftp-hpa-server = "tftpd-hpa.socket tftpd-hpa.service"
+SYSTEMD_AUTO_ENABLE:tftp-hpa-server = "enable"
diff --git a/meta-networking/recipes-daemons/vblade/vblade_25.bb b/meta-networking/recipes-daemons/vblade/vblade_25.bb
index 647abbfd26..15bf350c77 100644
--- a/meta-networking/recipes-daemons/vblade/vblade_25.bb
+++ b/meta-networking/recipes-daemons/vblade/vblade_25.bb
@@ -51,5 +51,5 @@ do_install() {
INITSCRIPT_NAME = "vblade"
INITSCRIPT_PARAMS = "start 30 . stop 70 0 1 2 3 4 5 6 ."
-SYSTEMD_SERVICE_${PN} = "vblade.service"
+SYSTEMD_SERVICE:${PN} = "vblade.service"
SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
index 024b776def..cf3d7fc966 100644
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
+++ b/meta-networking/recipes-daemons/vsftpd/vsftpd_3.0.3.bb
@@ -39,16 +39,16 @@ PACKAGECONFIG ??= "tcp-wrappers"
PACKAGECONFIG[tcp-wrappers] = ",,tcp-wrappers"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
-RDEPENDS_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-listfile', '', d)}"
+RDEPENDS:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-listfile', '', d)}"
PAMLIB = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '-L${STAGING_BASELIBDIR} -lpam', '', d)}"
WRAPLIB = "${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', '-lwrap', '', d)}"
NOPAM_SRC ="${@bb.utils.contains('PACKAGECONFIG', 'tcp-wrappers', 'file://nopam-with-tcp_wrappers.patch', 'file://nopam.patch', d)}"
inherit update-rc.d useradd systemd
-CONFFILES_${PN} = "${sysconfdir}/vsftpd.conf"
-LDFLAGS_append =" -lcrypt -lcap"
-CFLAGS_append_libc-musl = " -D_GNU_SOURCE -include fcntl.h"
+CONFFILES:${PN} = "${sysconfdir}/vsftpd.conf"
+LDFLAGS:append =" -lcrypt -lcap"
+CFLAGS:append:libc-musl = " -D_GNU_SOURCE -include fcntl.h"
EXTRA_OEMAKE = "-e MAKEFLAGS="
do_configure() {
@@ -95,17 +95,17 @@ do_install() {
}
INITSCRIPT_PACKAGES = "${PN}"
-INITSCRIPT_NAME_${PN} = "vsftpd"
-INITSCRIPT_PARAMS_${PN} = "defaults 80"
+INITSCRIPT_NAME:${PN} = "vsftpd"
+INITSCRIPT_PARAMS:${PN} = "defaults 80"
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp \
+USERADD_PARAM:${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp \
--shell /bin/false ftp "
-GROUPADD_PARAM_${PN} = "-r ftp"
+GROUPADD_PARAM:${PN} = "-r ftp"
-SYSTEMD_SERVICE_${PN} = "vsftpd.service"
+SYSTEMD_SERVICE:${PN} = "vsftpd.service"
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
if [ -z "$D" ]; then
if type systemd-tmpfiles >/dev/null; then
systemd-tmpfiles --create