aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-extended
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-12-13 10:13:42 +0800
committerKhem Raj <raj.khem@gmail.com>2019-12-15 19:30:15 -0800
commit57bc5310812d5e3c549b7744d5de3b32712563b1 (patch)
treea7511004b3db4e12823aa5578fdb2d109179a3c3 /meta-networking/recipes-extended
parent69bc6ff2fb3226c28cef532ffdc79d93581fcb6b (diff)
downloadmeta-openembedded-57bc5310812d5e3c549b7744d5de3b32712563b1.tar.gz
corosync: fix build error when package config rdma enabled
Fix corosync build error when package config rdma enabled. * replace dependency librdmacm from layer meta-cloud-services with rdma-core from meta-networking * add patch to fix issue that fail to find rdma library via pkgconfig Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-extended')
-rw-r--r--meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch32
-rw-r--r--meta-networking/recipes-extended/corosync/corosync_2.4.5.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch b/meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch
new file mode 100644
index 0000000000..bdc7645ce6
--- /dev/null
+++ b/meta-networking/recipes-extended/corosync/corosync/0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch
@@ -0,0 +1,32 @@
+Subject: [PATCH] configure.ac: fix pkgconfig issue of rdma
+
+pkgconfig files from rdma-core(https://github.com/linux-rdma/rdma-core)
+are named start with lib, such as librdmacm.pc and libibverbs.pc. When
+rdma support is enabled, it fails to find rdma related libraries. Update
+configure.ac to the issue.
+
+Upstream-Status: Submitted [https://github.com/corosync/corosync/pull/515]
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index ac513e93..240cfed4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -459,8 +459,8 @@ if test "x${enable_testagents}" = xyes; then
+ fi
+
+ if test "x${enable_rdma}" = xyes; then
+- PKG_CHECK_MODULES([rdmacm],[rdmacm])
+- PKG_CHECK_MODULES([ibverbs],[ibverbs])
++ PKG_CHECK_MODULES([rdmacm],[librdmacm])
++ PKG_CHECK_MODULES([ibverbs],[libibverbs])
+ AC_DEFINE_UNQUOTED([HAVE_RDMA], 1, [have rdmacm])
+ PACKAGE_FEATURES="$PACKAGE_FEATURES rdma"
+ WITH_LIST="$WITH_LIST --with rdma"
+--
+2.20.1
+
diff --git a/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb b/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb
index 1f4a3e1c6c..eefbcca8a1 100644
--- a/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb
+++ b/meta-networking/recipes-extended/corosync/corosync_2.4.5.bb
@@ -9,6 +9,7 @@ inherit autotools pkgconfig systemd useradd
SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \
file://corosync.conf \
+ file://0001-configure.ac-fix-pkgconfig-issue-of-rdma.patch \
"
SRC_URI[md5sum] = "e36a056b893c313c4ec1fe0d7e6cdebd"
@@ -36,7 +37,7 @@ PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
PACKAGECONFIG[qdevice] = "--enable-qdevices,--disable-qdevices"
PACKAGECONFIG[qnetd] = "--enable-qnetd,--disable-qnetd"
-PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma,librdmacm"
+PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma,rdma-core"
PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd"