aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-19 10:48:46 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-19 23:33:03 -0800
commit85bb13e02228018968c41b5c792da0a79eb330d3 (patch)
tree4ce93dda3d137e8039fafff8a7ebd4587fe8273c /meta-networking/recipes-extended
parent53d431639a1ef93992fa2b7da229f167e23e7a23 (diff)
downloadmeta-openembedded-85bb13e02228018968c41b5c792da0a79eb330d3.tar.gz
dlm: Drop -fstack-clash-protection for clang
-fstack-clash-protection is gcc-only option Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-extended')
-rw-r--r--meta-networking/recipes-extended/dlm/dlm_4.0.9.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb b/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
index 876462d2f0..6345c8141b 100644
--- a/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
+++ b/meta-networking/recipes-extended/dlm/dlm_4.0.9.bb
@@ -36,6 +36,10 @@ export EXTRA_OEMAKE = ""
DONTBUILD = "${@bb.utils.contains('PACKAGECONFIG', 'pacemaker', '', 'fence', d)}"
+do_compile_prepend_toolchain-clang() {
+ sed -i -e "s/-fstack-clash-protection//g" ${S}/*/Makefile
+}
+
do_compile_prepend() {
sed -i "s/libsystemd-daemon/libsystemd/g" ${S}/dlm_controld/Makefile
sed -i -e "s/ ${DONTBUILD}//g" ${S}/Makefile