aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-irc
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandro@enedino.org>2020-05-04 22:40:48 -0700
committerKhem Raj <raj.khem@gmail.com>2020-05-05 16:23:36 -0700
commit535385f3feaffa07ea23b3820cb1b916bef15f85 (patch)
treee5b7f1447288ded4419fb44476de89b4015d1573 /meta-networking/recipes-irc
parent157b563cc9842699824b16686f9803c203a193ed (diff)
downloadmeta-openembedded-535385f3feaffa07ea23b3820cb1b916bef15f85.tar.gz
weechat: introduce weechat recipe providing a fully working IRC client
Signed-off-by: Alejandro Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-irc')
-rw-r--r--meta-networking/recipes-irc/weechat/weechat/0001-use-pkg-config-for-gcrypt-instead.patch37
-rw-r--r--meta-networking/recipes-irc/weechat/weechat_2.8.bb32
2 files changed, 69 insertions, 0 deletions
diff --git a/meta-networking/recipes-irc/weechat/weechat/0001-use-pkg-config-for-gcrypt-instead.patch b/meta-networking/recipes-irc/weechat/weechat/0001-use-pkg-config-for-gcrypt-instead.patch
new file mode 100644
index 0000000000..0717e96546
--- /dev/null
+++ b/meta-networking/recipes-irc/weechat/weechat/0001-use-pkg-config-for-gcrypt-instead.patch
@@ -0,0 +1,37 @@
+From dc6b11f4cc6035b4701e1d7f7c91b2f45757e7a2 Mon Sep 17 00:00:00 2001
+From: Alejandro Enedino Hernandez Samaniego
+ <alejandro@enedino.org>
+Date: Wed, 26 Feb 2020 13:55:16 -0800
+Subject: [PATCH] use pkg-config for gcrypt instead
+
+Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org>
+
+Upstream-Status: Inappropriate [oe-specific]
+
+---
+ cmake/FindGCRYPT.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: weechat-2.7.1/cmake/FindGCRYPT.cmake
+===================================================================
+--- weechat-2.7.1.orig/cmake/FindGCRYPT.cmake
++++ weechat-2.7.1/cmake/FindGCRYPT.cmake
+@@ -27,15 +27,15 @@
+ # GCRYPT_LDFLAGS = ldflags to use to compile
+ #
+
+-find_program(LIBGCRYPT_CONFIG_EXECUTABLE NAMES libgcrypt-config)
++find_program(LIBGCRYPT_CONFIG_EXECUTABLE NAMES pkg-config)
+
+ set(GCRYPT_LDFLAGS)
+ set(GCRYPT_CFLAGS)
+
+ if(LIBGCRYPT_CONFIG_EXECUTABLE)
+
+- exec_program(${LIBGCRYPT_CONFIG_EXECUTABLE} ARGS --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE GCRYPT_LDFLAGS)
+- exec_program(${LIBGCRYPT_CONFIG_EXECUTABLE} ARGS --cflags RETURN_VALUE _return_VALUE OUTPUT_VARIABLE GCRYPT_CFLAGS)
++ exec_program(${LIBGCRYPT_CONFIG_EXECUTABLE} ARGS libgcrypt --libs RETURN_VALUE _return_VALUE OUTPUT_VARIABLE GCRYPT_LDFLAGS)
++ exec_program(${LIBGCRYPT_CONFIG_EXECUTABLE} ARGS libgcrypt --cflags RETURN_VALUE _return_VALUE OUTPUT_VARIABLE GCRYPT_CFLAGS)
+
+ if(${GCRYPT_CFLAGS} MATCHES "\n")
+ set(GCRYPT_CFLAGS " ")
diff --git a/meta-networking/recipes-irc/weechat/weechat_2.8.bb b/meta-networking/recipes-irc/weechat/weechat_2.8.bb
new file mode 100644
index 0000000000..cdfb1a963d
--- /dev/null
+++ b/meta-networking/recipes-irc/weechat/weechat_2.8.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Full-featured IRC plugin: multi-servers, proxy support, IPv6, SASL authentication, nicklist, DCC, and many other features"
+HOMEPAE = "https://weechat.org/"
+SECTION = "net"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
+
+DEPENDS = "openssl zlib icu libgcrypt gnutls curl aspell"
+
+SRC_URI = "https://weechat.org/files/src/weechat-${PV}.tar.xz \
+ file://0001-use-pkg-config-for-gcrypt-instead.patch \
+ "
+SRC_URI[sha256sum] = "553ea295edad3b03cf88e6029c21e7bde32ff1cc026d35386ba9da3e56a6018c"
+
+inherit cmake pkgconfig
+
+PACKAGECONFIG ??= " ncurses python"
+PACKAGECONFIG[ncurses] = "-DENABLE_NCURSES=ON,-DENABLE_NCURSES=OFF,ncurses"
+PACKAGECONFIG[python] = "-DENABLE_PYTHON=ON,-DENABLE_PYTHON=OFF,python3"
+
+EXTRA_OECMAKE_append = " -DENABLE_PHP=OFF -DENABLE_TCL=OFF -DENABLE_LUA=OFF -DENABLE_JAVASCRIPT=OFF -DENABLE_RUBY=OFF -DENABLE_GUILE=OFF -DENABLE_PERL=OFF -DENABLE_ASPELL=ON"
+
+do_configure_prepend(){
+ # Make sure we get dependencies from recipe-sysroot
+ sed -i -e 's# /usr/bin# ${RECIPE_SYSROOT}/${bindir}/#g' ${S}/cmake/FindPerl.cmake
+ sed -i -e 's# /usr/local/bin##g' ${S}/cmake/FindPerl.cmake
+ sed -i -e 's# /usr/pkg/bin##g' ${S}/cmake/FindPerl.cmake
+}
+
+do_install_append(){
+ rm -rf ${D}/${datadir}
+}
+