aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-02 10:34:05 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:27 +0200
commit80cf5e0ee961436fbcb2fa2c03cb709f79fa9e3c (patch)
treea86f62dd2dbf13dca2c72c67cf3c7a517a1b3c72 /meta-networking/recipes-kernel
parent55cb2ec6db42e43c601f77bf4f03fb3a43725b24 (diff)
downloadmeta-openembedded-80cf5e0ee961436fbcb2fa2c03cb709f79fa9e3c.tar.gz
netmap-modules: Avoid type warning with python v3
Python 3 is stricter about type comparisions, this avoids warnings. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-kernel')
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap-modules_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
index 406a4f3cff..6544bb5db7 100644
--- a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
+++ b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
@@ -70,7 +70,7 @@ do_configure_append () {
#define NETMAP_LINUX_HAVE_E1000E_DOWN2
EOF
-if ${@ 'false' if (bb.utils.vercmp_string(d.getVar('KERNEL_VERSION', True), '3.17') < 0) else 'true' } ; then
+if ${@ 'false' if (bb.utils.vercmp_string(d.getVar('KERNEL_VERSION', True) or "0", '3.17') < 0) else 'true' } ; then
echo OK
cat >> ${S}/LINUX/netmap_linux_config.h <<EOF
#define NETMAP_LINUX_ALLOC_NETDEV_4ARGS