aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-20 13:48:12 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-21 16:35:25 -0700
commit63ebd02d22784519efb31273832e69476b0c8b64 (patch)
tree426cfbfde0990321b9a780ae0eccd0a5b459e80d /meta-networking/recipes-kernel
parent4c84ab39b3234a6266275352cd827ab114ff46d9 (diff)
downloadmeta-openembedded-63ebd02d22784519efb31273832e69476b0c8b64.tar.gz
wireguard-module: Exlude from world builds
Moving beyond kernel 5.6, this kmod is not needed and core has moved the reference kernel to 5.8 for reference machines wireguard-tools should RDEPEND but not DEPEND Remove it from meta-networking packagegroup as well Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-kernel')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200712.bb5
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20200513.bb5
2 files changed, 8 insertions, 2 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200712.bb b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200712.bb
index bc94e29ea3..3a83e48eea 100644
--- a/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200712.bb
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20200712.bb
@@ -33,3 +33,8 @@ module_do_install() {
install -m 0644 ${MODULE_NAME}.ko \
${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
}
+
+# WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required.
+# OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds
+# for reference machines e.g. qemu
+EXCLUDE_FROM_WORLD = "1"
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20200513.bb b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20200513.bb
index c24e3438c7..31b33a045d 100644
--- a/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20200513.bb
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-tools_1.0.20200513.bb
@@ -5,7 +5,7 @@ SRC_URI = "git://git.zx2c4.com/wireguard-tools"
inherit bash-completion systemd pkgconfig
-DEPENDS += "wireguard-module libmnl"
+DEPENDS += "libmnl"
do_install () {
oe_runmake DESTDIR="${D}" PREFIX="${prefix}" SYSCONFDIR="${sysconfdir}" \
@@ -22,4 +22,5 @@ FILES_${PN} = " \
${bindir} \
"
-RDEPENDS_${PN} = "wireguard-module bash"
+RDEPENDS_${PN} = "bash"
+RRECOMMENDS_${PN} = "kernel-module-wireguard"