aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/fwknop
diff options
context:
space:
mode:
authorAlexandru Moise <00moses.alexander00@gmail.com>2016-11-06 01:27:35 +0200
committerJoe MacDonald <joe_macdonald@mentor.com>2016-12-14 09:20:09 -0500
commit961ed807dadb15108c7fdc020f66ec52c17310bf (patch)
treeabb30c5a746eb028cdffee5764feb403a5ee3d8f /meta-networking/recipes-support/fwknop
parent25437c58a027b8a3d643d4d3caa13da07a690431 (diff)
downloadmeta-openembedded-961ed807dadb15108c7fdc020f66ec52c17310bf.tar.gz
fwknop: Initial add 2.6.9
fwknop is a SPA (Single Packet Authorization) scheme for strong service concealment. Modern alternative to port knocking using a single encrypted packet for authentification with a firewall. Signed-off-by: Alexandru Moise <00moses.alexander00@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/fwknop')
-rw-r--r--meta-networking/recipes-support/fwknop/fwknop_2.6.9.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/fwknop/fwknop_2.6.9.bb b/meta-networking/recipes-support/fwknop/fwknop_2.6.9.bb
new file mode 100644
index 0000000000..49b11ad335
--- /dev/null
+++ b/meta-networking/recipes-support/fwknop/fwknop_2.6.9.bb
@@ -0,0 +1,34 @@
+SUMMARY = "fwknop - Single Packet Authorization"
+HOMEPAGE = "http://www.cipherdyne.org/fwknop/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
+ "
+inherit autotools-brokensep
+
+SRC_URI = "http://www.cipherdyne.org/${BPN}/download/${BPN}-${PV}.tar.bz2 \
+ "
+
+SRC_URI[md5sum] = "e2c49e9674888a028bd443a55c3aaa22"
+SRC_URI[sha256sum] = "5bf47fe1fd30e862d29464f762c0b8bf89b5e298665c37624d6707826da956d4"
+
+DEPENDS = "libpcap gpgme"
+
+EXTRA_OECONF = " --with-iptables=/usr/sbin/iptables \
+ "
+
+do_configure () {
+ aclocal
+ libtoolize --automake --copy --force
+ autoconf
+ autoheader
+ automake -a
+ oe_runconf
+}
+
+PACKAGES =+ "${PN}-client ${PN}-daemon"
+
+FILES_${PN}-client = "${bindir}/fwknop"
+FILES_${PN}-daemon = "${sbindir}/fwknopd \
+ ${sysconfdir}/fwknop/access.conf \
+ ${sysconfdir}/fwknop/fwknopd.conf"
+