aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-08-19 17:38:32 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2014-09-08 16:36:08 -0400
commitab6a7fa8dd79754b7c464d6637ce8ce62eb7af7e (patch)
tree86177aa88c794375e7908550bfd3575ea1ba2de1 /meta-networking/recipes-support/memcached/memcached_1.4.17.bb
parent46824934fa4ac6a61bebe2c92faa31c0a8e85392 (diff)
downloadmeta-openembedded-ab6a7fa8dd79754b7c464d6637ce8ce62eb7af7e.tar.gz
memcached: add knob to detect whether hugetlbfs are checked
Add knob to detect whether hugetlbfs are checked or not. This patch fixed the error: ld: cannot find -lhugetlbfs Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/memcached/memcached_1.4.17.bb')
-rw-r--r--meta-networking/recipes-support/memcached/memcached_1.4.17.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/memcached/memcached_1.4.17.bb b/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
index 5d37df08a3..e61bc74cb9 100644
--- a/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
+++ b/meta-networking/recipes-support/memcached/memcached_1.4.17.bb
@@ -18,7 +18,11 @@ DEPENDS += "libevent"
RDEPENDS_${PN} += "perl perl-module-posix perl-module-autoloader perl-module-tie-hash"
SRC_URI = "http://www.memcached.org/files/${BP}.tar.gz \
- file://configure.patch"
+ file://configure.patch \
+ file://memcached-add-hugetlbfs-check.patch"
+
+# set the same COMPATIBLE_HOST as libhugetlbfs
+COMPATIBLE_HOST = '(i.86|x86_64|powerpc|powerpc64|arm).*-linux'
SRC_URI[md5sum] = "46402dfbd7faadf6182283dbbd18b1a6"
SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8cdc0458"
@@ -26,11 +30,14 @@ SRC_URI[sha256sum] = "d9173ef6d99ba798c982ea4566cb4f0e64eb23859fdbf9926a89999d8c
python __anonymous () {
endianness = d.getVar('SITEINFO_ENDIANNESS', True)
if endianness == 'le':
- d.setVar('EXTRA_OECONF', "ac_cv_c_endian=little")
+ d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=little")
else:
- d.setVar('EXTRA_OECONF', "ac_cv_c_endian=big")
+ d.appendVar('EXTRA_OECONF', " ac_cv_c_endian=big")
}
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[hugetlbfs] = "--enable-hugetlbfs, --disable-hugetlbfs, libhugetlbfs"
+
inherit update-rc.d
INITSCRIPT_NAME = "memcached"