aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/netcat
diff options
context:
space:
mode:
authorLei Yang <lei.yang@windriver.com>2013-01-07 01:38:24 +0000
committerJoe MacDonald <joe.macdonald@windriver.com>2013-01-07 15:20:37 -0500
commit7bbb2e57c3c0e170844d24b69b2986c278977a16 (patch)
tree7b49d50c5c70281bea326ed923350aaff63656d0 /meta-networking/recipes-support/netcat
parenta0292fc5fc84ac016392706de0a531e3ca2b03ea (diff)
downloadmeta-openembedded-7bbb2e57c3c0e170844d24b69b2986c278977a16.tar.gz
Add netcat-bsd into meta-networking for meta-virutalization libvirt virt-test
The netcat-openbsd in meta-virtualization layer has bugs. This update version will fix "nc: Protocol no available." error. As bruce point, we want to keep netcat in the meta-networking, which meta-virtualization will depend on,and this patch will let netcat-openbsd with low priority to install Signed-off-by: Lei Yang <lei.yang@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking/recipes-support/netcat')
-rw-r--r--meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb30
-rw-r--r--meta-networking/recipes-support/netcat/netcat.inc5
-rw-r--r--meta-networking/recipes-support/netcat/netcat_0.7.1.bb11
3 files changed, 40 insertions, 6 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb b/meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb
new file mode 100644
index 0000000000..f83caee94f
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb
@@ -0,0 +1,30 @@
+require netcat.inc
+DESCRIPTION = "OpenBSD Netcat"
+HOMEPAGE = "http://ftp.debian.org"
+LICENSE = "BSD-3-Clause"
+PR = "r0"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_1.89.orig.tar.gz;name=netcat \
+ ${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_1.89-4.diff.gz;name=netcat-patch"
+
+SRC_URI[netcat.md5sum] = "7238ce15aae43069e96ba7faf03f153e"
+SRC_URI[netcat.sha256sum] = "72e844dde8a2a7cba61971d493758dbea9ef0b164bccef15fd4a36490dc77f2b"
+SRC_URI[netcat-patch.md5sum] = "00c65aa22243b76998174c733cbb64cc"
+SRC_URI[netcat-patch.sha256sum] = "d5b6b2bd9788114bdcfbb71acad0263720b4fdc41529e287adf451b8610f84f1"
+
+S = "${WORKDIR}/${PN}-${PV}.orig"
+
+do_configure[noexec] = "1"
+
+do_compile() {
+ cd ${S}
+ while read line; do patch -p1 <debian/patches/$line; done <debian/patches/series
+ pkgrel=4
+ oe_runmake CFLAGS="$CFLAGS -DDEBIAN_VERSION=\"\\\"${pkgrel}\\\"\""
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 ${S}/nc ${D}${bindir}/nc.${PN}
+}
+ALTERNATIVE_PRIORITY = "50"
diff --git a/meta-networking/recipes-support/netcat/netcat.inc b/meta-networking/recipes-support/netcat/netcat.inc
new file mode 100644
index 0000000000..6c815d97e6
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat.inc
@@ -0,0 +1,5 @@
+SECTION = "console/network"
+inherit update-alternatives gettext
+
+ALTERNATIVE_${PN} = "nc"
+
diff --git a/meta-networking/recipes-support/netcat/netcat_0.7.1.bb b/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
index c5ab85d19b..c4f1f331aa 100644
--- a/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
+++ b/meta-networking/recipes-support/netcat/netcat_0.7.1.bb
@@ -1,21 +1,20 @@
+require netcat.inc
DESCRIPTION = "GNU Netcat"
HOMEPAGE = "http://netcat.sourceforge.net"
-SECTION = "console/network"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-PR = "r0"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/netcat/netcat-${PV}.tar.bz2"
SRC_URI[md5sum] = "0a29eff1736ddb5effd0b1ec1f6fe0ef"
SRC_URI[sha256sum] = "b55af0bbdf5acc02d1eb6ab18da2acd77a400bafd074489003f3df09676332bb"
-inherit autotools update-alternatives gettext
+inherit autotools
do_install_append() {
- mv ${D}${bindir}/nc ${D}${bindir}/nc.${PN}
+ install -d ${D}${bindir}
+ mv ${D}${bindir}/nc ${D}${bindir}/nc.${PN}
}
-
-ALTERNATIVE_${PN} = "nc"
ALTERNATIVE_PRIORITY = "100"