aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nghttp2/nghttp2_1.44.0.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-07-25 00:46:05 +0800
committerArmin Kuster <akuster808@gmail.com>2021-08-01 09:22:21 -0700
commitcfbf2182a715d185262f2c5f00b8866084f6f078 (patch)
treeb1e7a8194ea78a19790dccc52c86b95a34776d19 /meta-networking/recipes-support/nghttp2/nghttp2_1.44.0.bb
parenta473f6d52dfaf30a065b97b8454c865add93743b (diff)
downloadmeta-openembedded-cfbf2182a715d185262f2c5f00b8866084f6f078.tar.gz
nghttp2: upgrade 1.43.0 -> 1.44.0
v1.44.0 changelog: lib: Port new ngtcp2 map implementation doc: Replace master with main build: Add precious variables for libev and jemalloc and use JEMALLOC_CFLAGS build: Add more --with-* configure flags build: Add LIBTOOL_LDFLAGS configure variable third-party: Bump llhttp to 6.0.2 src: Replace black-list with block-list nghttpx: Fix max distance in weight group/address cycle comparison nghttpx: Set connect_blocker and live_check after shuffling addresses nghttpx: Replace master with main nghttpx: Remove trailing white space after $method log variable (https://github.com/nghttp2/nghttp2/pull/1553) h2load: Add --rps option (https://github.com/nghttp2/nghttp2/pull/1559) h2load: Allow unit in -D option asio: fix some typos (Patch from Jan Kundrát) (https://github.com/nghttp2/nghttp2/pull/1550) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit b767b37e3aabc3c9e95adb7eb469bd6d32979fb8) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/nghttp2/nghttp2_1.44.0.bb')
-rw-r--r--meta-networking/recipes-support/nghttp2/nghttp2_1.44.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nghttp2/nghttp2_1.44.0.bb b/meta-networking/recipes-support/nghttp2/nghttp2_1.44.0.bb
new file mode 100644
index 0000000000..32a9307c3f
--- /dev/null
+++ b/meta-networking/recipes-support/nghttp2/nghttp2_1.44.0.bb
@@ -0,0 +1,40 @@
+SUMMARY = "HTTP/2 C Library and tools"
+HOMEPAGE = "https://nghttp2.org/"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
+DEPENDS = "c-ares cunit jansson libev libevent libxml2 openssl zlib"
+
+UPSTREAM_CHECK_URI = "https://github.com/nghttp2/nghttp2/releases"
+
+SRC_URI = "\
+ https://github.com/nghttp2/nghttp2/releases/download/v${PV}/nghttp2-${PV}.tar.xz \
+ file://0001-fetch-ocsp-response-use-python3.patch \
+"
+SRC_URI[sha256sum] = "5699473b29941e8dafed10de5c8cb37a3581edf62ba7d04b911ca247d4de3c5d"
+
+inherit cmake manpages python3native
+PACKAGECONFIG[manpages] = ""
+
+# examples are never installed, and don't need to be built in the
+# first place
+EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=ON"
+
+do_install_append() {
+ rm ${D}${bindir}/deflatehd ${D}${bindir}/inflatehd
+}
+
+PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
+
+RDEPENDS_${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
+RDEPENDS_${PN}_class-native = ""
+RDEPENDS_${PN}-proxy = "openssl python3-core python3-io python3-shell"
+
+ALLOW_EMPTY_${PN} = "1"
+FILES_${PN} = ""
+FILES_lib${PN} = "${libdir}/*${SOLIBS}"
+FILES_${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
+FILES_${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
+FILES_${PN}-server = "${bindir}/nghttpd"
+
+BBCLASSEXTEND = "native"