aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nghttp2
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-11-07 11:44:02 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-07 17:43:44 -0800
commit0c6c10873a449c9b9c54c157dc7fb00ea280c7a9 (patch)
treee867ba53af1414ab8939f0e9282266a8cdda158e /meta-networking/recipes-support/nghttp2
parent98d1225cb12d2c73007800a5d9a3f2586780b27f (diff)
downloadmeta-openembedded-0c6c10873a449c9b9c54c157dc7fb00ea280c7a9.tar.gz
nghttp2: allow to build a -native package
This will e.g. enable us to use it from nodejs-native. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/nghttp2')
-rw-r--r--meta-networking/recipes-support/nghttp2/nghttp2_1.39.2.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nghttp2/nghttp2_1.39.2.bb b/meta-networking/recipes-support/nghttp2/nghttp2_1.39.2.bb
index 7a475050f4..c27afdb551 100644
--- a/meta-networking/recipes-support/nghttp2/nghttp2_1.39.2.bb
+++ b/meta-networking/recipes-support/nghttp2/nghttp2_1.39.2.bb
@@ -28,6 +28,7 @@ do_install_append() {
PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
RDEPENDS_${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
+RDEPENDS_${PN}_class-native = ""
RDEPENDS_${PN}-proxy = "openssl python3-core python3-io python3-shell"
ALLOW_EMPTY_${PN} = "1"
@@ -36,3 +37,5 @@ FILES_lib${PN} = "${libdir}/*${SOLIBS}"
FILES_${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
FILES_${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
FILES_${PN}-server = "${bindir}/nghttpd"
+
+BBCLASSEXTEND = "native"