aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nis/nis.inc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-06 00:06:28 -0800
committerKhem Raj <raj.khem@gmail.com>2013-01-08 09:31:44 -0800
commit5d56edf7a7dc53f92e954fbf92238409c1e183e8 (patch)
treef12fa3dfb2d530026f44fa13e9133f4321c7d789 /meta-networking/recipes-support/nis/nis.inc
parent4c735f36f64476320c130ffe14a5c831f65b9c42 (diff)
downloadmeta-openembedded-5d56edf7a7dc53f92e954fbf92238409c1e183e8.tar.gz
nis: Import recipes from OE classic
Update to latest versions while at it Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/nis/nis.inc')
-rw-r--r--meta-networking/recipes-support/nis/nis.inc31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nis/nis.inc b/meta-networking/recipes-support/nis/nis.inc
new file mode 100644
index 0000000000..f9f5bd1b42
--- /dev/null
+++ b/meta-networking/recipes-support/nis/nis.inc
@@ -0,0 +1,31 @@
+# This include file contains global definitions for the
+# various NIS packages.
+#
+# These packages will only function correctly with glibc -
+# the rpcsvc functionality is not present in uclibc
+DESCRIPTION = "NIS Server and Tools"
+HOMEPAGE = "http://www.linux-nis.org/nis/"
+SECTION = "console/network"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+inherit autotools gettext
+
+# install is broken because src/Makefile heroically adds '-s'
+# to the install flags - passing -s to the build /usr/bin/install!
+# install-strip gets it right but installs ypbind -m <default>,
+# not -m 555. In an OE build this is not, so far as I can see,
+# a security problem (and this fix to the build problem is *much*
+# easier and more maintainable.)
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install-strip
+}
+
+# An attempt to build on uclibc will fail, causing annoyance,
+# so force the package to be skipped here (this will cause a
+# 'nothing provides' error)
+python () {
+ os = bb.data.getVar("TARGET_OS", d, 1)
+ if os == "linux-uclibc":
+ raise bb.parse.SkipPackage("NIS functionality requires rpcsvc/yp.h, uClibC does not provide this")
+}