aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/openvpn
diff options
context:
space:
mode:
authorRichard Tollerton <rich.tollerton@ni.com>2014-07-18 16:14:36 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:58 +0200
commitf647f319fcf1ca4844039a83fbc38acbd4ac762e (patch)
tree6a6db7f6507a7f0b3cb8d2be4ec3035504086b9c /meta-networking/recipes-support/openvpn
parent6d72c926e06000c634c221883dee8af8be8f1217 (diff)
downloadmeta-openembedded-f647f319fcf1ca4844039a83fbc38acbd4ac762e.tar.gz
openvpn: update and enable iproute2 support
- Added .bb for version 2.3.4. - The download URL was broken; it's changed to reflect where the website points to. - Force use of iproute2, which is generally recommended when running OpenVPN as an unprivileged user. Ref: http://community.openvpn.net/openvpn/wiki/UnprivilegedUser - Explicitly add libpam to DEPENDS if pam is enabled, and disable the auth-pam plugin if pam is not enabled. - Pass the path to the 'ip' utility to the configure script to keep it from trying to find it on the host. Signed-off-by: Richard Tollerton <rich.tollerton@ni.com> Signed-off-by: Ben Shelton <ben.shelton@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/openvpn')
-rw-r--r--meta-networking/recipes-support/openvpn/openvpn_2.1.3.bb27
-rw-r--r--meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb31
2 files changed, 31 insertions, 27 deletions
diff --git a/meta-networking/recipes-support/openvpn/openvpn_2.1.3.bb b/meta-networking/recipes-support/openvpn/openvpn_2.1.3.bb
deleted file mode 100644
index 9ef0fbf0b5..0000000000
--- a/meta-networking/recipes-support/openvpn/openvpn_2.1.3.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY = "A full-featured SSL VPN solution via tun device"
-HOMEPAGE = "http://openvpn.sourceforge.net"
-SECTION = "console/network"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=5aac200199fde47501876cba7263cb0c"
-DEPENDS = "lzo openssl"
-
-inherit autotools
-
-SRC_URI = "http://openvpn.net/release/openvpn-${PV}.tar.gz \
- file://openvpn"
-
-SRC_URI[md5sum] = "7486d3e270ba4b033e311d3e022a0ad7"
-SRC_URI[sha256sum] = "5185181df2e6043bd667377bc92e36ea5a5bd7600af209654f109b6403ca5b36"
-
-CFLAGS += "-fno-inline"
-
-# I want openvpn to be able to read password from file (hrw)
-EXTRA_OECONF += "--enable-password-save"
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/init.d
- install -d ${D}/${sysconfdir}/openvpn
- install -m 755 ${WORKDIR}/openvpn ${D}/${sysconfdir}/init.d
-}
-
-RRECOMMENDS_${PN} = "kernel-module-tun"
diff --git a/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb b/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb
new file mode 100644
index 0000000000..a3322a0c59
--- /dev/null
+++ b/meta-networking/recipes-support/openvpn/openvpn_2.3.4.bb
@@ -0,0 +1,31 @@
+SUMMARY = "A full-featured SSL VPN solution via tun device."
+HOMEPAGE = "http://openvpn.sourceforge.net"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5aac200199fde47501876cba7263cb0c"
+DEPENDS = "lzo openssl iproute2 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
+
+inherit autotools
+
+SRC_URI = "http://swupdate.openvpn.org/community/releases/openvpn-${PV}.tar.gz \
+ file://openvpn"
+
+SRC_URI[md5sum] = "04d47237907faabe9d046970ffe44b2e"
+SRC_URI[sha256sum] = "af506d5f48568fa8d2f2435cb3fad35f9a9a8f263999ea6df3ba296960cec85a"
+
+CFLAGS += "-fno-inline"
+
+# I want openvpn to be able to read password from file (hrw)
+EXTRA_OECONF += "--enable-password-save --enable-iproute2"
+EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'pam', '', '--disable-plugin-auth-pam', d)}"
+EXTRA_OECONF += "IPROUTE=/bin/ip"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}/${sysconfdir}/openvpn
+ install -m 755 ${WORKDIR}/openvpn ${D}/${sysconfdir}/init.d
+}
+
+RRECOMMENDS_${PN} = "kernel-module-tun"
+
+FILES_${PN}-dbg += "/usr/lib/openvpn/plugins/.debug"