aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-04-25 09:53:17 -0700
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:40 -0700
commit5194d3590b031bb055a260e2418cdc2f684b20fa (patch)
treee191fd64da0024d704d05bad9467701caab8d798 /meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
parentdf1cc5a3c73bf9629f0066fe55afab5f9c47a0cf (diff)
downloadmeta-openembedded-5194d3590b031bb055a260e2418cdc2f684b20fa.tar.gz
wireshark: update package to 2.0.3
No CVE's assigned. The following vulnerabilities have been fixed: * [1]wnpa-sec-2016-19 The NCP dissector could crash. ([2]Bug 11591) * [3]wnpa-sec-2016-20 TShark could crash due to a packet reassembly bug. ([4]Bug 11799) * [5]wnpa-sec-2016-21 The IEEE 802.11 dissector could crash. ([6]Bug 11824, [7]Bug 12187) * [8]wnpa-sec-2016-22 The PKTC dissector could crash. ([9]Bug 12206) * [10]wnpa-sec-2016-23 The PKTC dissector could crash. ([11]Bug 12242) * [12]wnpa-sec-2016-24 The IAX2 dissector could go into an infinite loop. ([13]Bug 12260) * [14]wnpa-sec-2016-25 Wireshark and TShark could exhaust the stack. ([15]Bug 12268) * [16]wnpa-sec-2016-26 The GSM CBCH dissector could crash. ([17]Bug 12278) * [18]wnpa-sec-2016-27 MS-WSP dissector crash. ([19]Bug 12341) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> (cherry picked from commit 7a9c626092c7d3b10206c7ca4ea2827cca9cba4f) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb b/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
new file mode 100644
index 0000000000..76cb30a915
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/wireshark_2.0.3.bb
@@ -0,0 +1,60 @@
+DESCRIPTION = "wireshark - a popular network protocol analyzer"
+HOMEPAGE = "http://www.wireshark.org"
+SECTION = "net"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
+
+DEPENDS = "perl-native pcre expat glib-2.0 sbc"
+
+SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2"
+
+SRC_URI[md5sum] = "62dc20f5a77542feed2e38f18db8ae3b"
+SRC_URI[sha256sum] = "e196376e75fe21fdef41b4eaa27ce2e1b2b561e7f7b20328a8e96657cc4465fc"
+
+PE = "1"
+
+inherit autotools pkgconfig
+
+ARM_INSTRUCTION_SET = "arm"
+
+# Works with either gtk+ or gtk3.
+WHICH_GTK = "gtk+"
+
+PACKAGECONFIG ?= "libpcap gnutls libnl libcap"
+PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}"
+PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
+#PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}"
+
+PACKAGECONFIG[libcap] = "--with-libcap=${STAGING_LIBDIR}, --with-libcap=no --enable-pcap-ng-default , libcap"
+PACKAGECONFIG[libpcap] = "--with-pcap=${STAGING_LIBDIR} --with-pcap-remote, --with-pcap=no --enable-pcap-ng-default , libpcap"
+PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
+PACKAGECONFIG[libnl] = "--with-libnl=yes, --with-libnl=no, libnl"
+PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
+PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+"
+PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3"
+PACKAGECONFIG[graphics] = "--enable-wireshark, --disable-wireshark,"
+PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
+PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
+PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
+PACKAGECONFIG[ssl] = "--with-ssl=yes, --with-ssl=no, openssl"
+PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
+PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua"
+PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib"
+PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip"
+PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no"
+
+# these next two options require addional layers
+PACKAGECONFIG[adns] = "--with-adns=yes, --with-adns=no, adns"
+PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares"
+
+EXTRA_OECONF += "--with-qt=no --enable-usr-local=no --enable-tshark --enable-rawshark"
+
+do_configure_prepend() {
+ # force to use fallback
+ sed -i -e '/^glib_prefix/s/=.*$/=""/' ${S}/aclocal-flags
+}
+
+ALLOW_EMPTY_${PN} = "1"
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+FILES_${PN} += "${datadir}*"