aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-09-24 13:54:15 +0100
committerJoe MacDonald <joe@deserted.net>2013-09-24 09:04:55 -0400
commit7e0bdfc5ecf7c551416e2a193c9220347d8fe03f (patch)
tree14a5e837b5c77f57492ce3548643073bbdc45c2e /meta-networking/recipes-support
parent1c4921817e202909ae97e8108ab1de17ca14f6ce (diff)
downloadmeta-openembedded-7e0bdfc5ecf7c551416e2a193c9220347d8fe03f.tar.gz
lowpan-tools: add git version
The 0.3 release was a year ago and git HEAD contains fixes to make it work with contiki, so build from git instead of backporting all of the patches. Based on a patch by Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
new file mode 100644
index 0000000000..cf78b45759
--- /dev/null
+++ b/meta-networking/recipes-support/lowpan-tools/lowpan-tools_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Utilities for managing the Linux LoWPAN stack"
+DESCRIPTION = "This is a set of utils to manage the Linux LoWPAN stack. \
+The LoWPAN stack aims for IEEE 802.15.4-2003 (and for lesser extent IEEE 802.15.4-2006) compatibility."
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS = "libnl python"
+
+PV = "0.3+git${SRCPV}"
+SRC_URI = "git://linux-zigbee.git.sourceforge.net/gitroot/linux-zigbee/linux-zigbee"
+SRCREV = "a1d9615adde6d1a568813c24a128273ed755af04"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+do_install_append() {
+ rmdir ${D}${localstatedir}/run
+}
+
+FILES_${PN}-dbg += "${libexecdir}/lowpan-tools/.debug/"
+
+PACKAGES =+ "${PN}-python"
+FILES_${PN}-python = "${libdir}/python*"