aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-11-04 00:49:42 -0500
committerJoe MacDonald <joe@deserted.net>2013-11-06 15:12:45 -0500
commita1b14825aaef4e3430849bd9e3f93302b2f83af1 (patch)
tree41e4be70bc8f8f7b0b1f044b56b88c870672c6e3 /meta-networking/recipes-support
parente854d0d71ea957d0fac78135bb67d1a0c70eeb2b (diff)
downloadmeta-openembedded-a1b14825aaef4e3430849bd9e3f93302b2f83af1.tar.gz
netcf: move from meta-virtualization to meta-networking
netcf was orginally introduced in meta-virtualization, since it provides functionality required by libvirt, but it is otherwise not bound to virtualization. So we can move it to meta-networking, and in the process uprev to the the latest 0.2.3 functinality. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/netcf/netcf_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/netcf/netcf_git.bb b/meta-networking/recipes-support/netcf/netcf_git.bb
new file mode 100644
index 0000000000..60d82d1078
--- /dev/null
+++ b/meta-networking/recipes-support/netcf/netcf_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "netcf"
+DESCRIPTION = "netcf is a cross-platform network configuration library."
+HOMEPAGE = "https://fedorahosted.org/netcf/"
+SECTION = "console/tools"
+LICENSE = "LGPLv2.1"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbb461211a33b134d42ed5ee802b37ff"
+
+SRCREV = "b8a19dc860b38c97c42115d8a559b78853452a4b"
+PV = "0.2.3+git${SRCPV}"
+
+SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git \
+"
+
+DEPENDS += "augeas libnl libxslt libxml2"
+
+S = "${WORKDIR}/git"
+
+inherit gettext autotools
+
+do_configure_prepend() {
+ cd ${S}
+ ./bootstrap
+}
+