aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorPeter Bigot <pab@pabigot.com>2014-08-28 07:06:17 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-01 11:37:11 +0200
commit6bea4ca22eb0ee33a1d9f6d6dd2d4a978a261515 (patch)
tree4013e51e2667373d95ee20dedc618ecf86f0cabd /meta-networking/recipes-support
parent1513d0e31f609ffcde9a116a50bfb0360b9e7ecf (diff)
downloadmeta-openembedded-6bea4ca22eb0ee33a1d9f6d6dd2d4a978a261515.tar.gz
ntp: re-enable server debugging and control by PACKAGECONFIG
The description in a previous patch to disable debugging is incorrect. Although the option is default-enabled in configure.ac, configure does respect the option that disables it. In ntp 4.2.7 the option code is refactored to ntp_debug.m4 and has an effect in sntp as well. Adding --disable-debugging to the top-level configure options overrides the default for both 4.2.6 and 4.2.7 without patching the distribution. Make the selection explicit and configurable, but restore the historical default. Absence of debugging capability in the server makes it difficult to validate complex configurations. Signed-off-by: Peter A. Bigot <pab@pabigot.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/ntp/files/ntp-disable-debugging.patch23
-rw-r--r--meta-networking/recipes-support/ntp/ntp.inc5
2 files changed, 3 insertions, 25 deletions
diff --git a/meta-networking/recipes-support/ntp/files/ntp-disable-debugging.patch b/meta-networking/recipes-support/ntp/files/ntp-disable-debugging.patch
deleted file mode 100644
index 242276edb0..0000000000
--- a/meta-networking/recipes-support/ntp/files/ntp-disable-debugging.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-set ntp_ok to no if ntp debugging is not enabled.
-
-Upstream-status: Pending
-
-There is a problem in configure.ac file that whether or not
-'--enable-debugging' is specified in configure cmdline, debugging
-is always enabled.
-We should disable ntp debugging by default.
-
-Signed-off-by: Xufeng Zhang <xufeng.zhang@windriver.com>
-
----
---- a/configure.ac
-+++ b/configure.ac
-@@ -2458,7 +2458,7 @@
- [+ include ntpd debugging code]
- )],
- [ntp_ok=$enableval],
-- [ntp_ok=yes]
-+ [ntp_ok=no]
- )
- case "$ntp_ok" in
- yes)
diff --git a/meta-networking/recipes-support/ntp/ntp.inc b/meta-networking/recipes-support/ntp/ntp.inc
index b63f202fe5..55926e064a 100644
--- a/meta-networking/recipes-support/ntp/ntp.inc
+++ b/meta-networking/recipes-support/ntp/ntp.inc
@@ -23,7 +23,6 @@ SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.g
file://sntp.service \
file://sntp \
file://ntpd.list \
- file://ntp-disable-debugging.patch \
file://CVE-2013-5211.patch \
"
@@ -38,7 +37,8 @@ USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ntp \
--shell /bin/false --user-group ntp"
-PACKAGECONFIG ??= "cap"
+# NB: debug is default-enabled by NTP; keep it default-enabled here.
+PACKAGECONFIG ??= "cap debug"
PACKAGECONFIG[openssl] = "--with-openssl-libdir=${STAGING_LIBDIR} \
--with-openssl-incdir=${STAGING_INCDIR} \
--with-crypto, \
@@ -46,6 +46,7 @@ PACKAGECONFIG[openssl] = "--with-openssl-libdir=${STAGING_LIBDIR} \
openssl"
PACKAGECONFIG[cap] = "--enable-linuxcaps,--disable-linuxcaps,libcap"
PACKAGECONFIG[readline] = "--with-lineeditlibs,--without-lineeditlibs,readline"
+PACKAGECONFIG[debug] = "--enable-debugging,--disable-debugging"
do_install_append() {
install -d ${D}${sysconfdir}/init.d