aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorJonathan Richardson <jonathan.richardson@broadcom.com>2020-04-08 16:01:20 -0700
committerKhem Raj <raj.khem@gmail.com>2020-04-08 18:16:19 -0700
commit9656d77b3996acf47973cd7bd91879b409d77a45 (patch)
tree090b0978041c27819a4dccba1f8deefba24bc1e4 /meta-networking/recipes-support
parentd28cb81c5fa266cfa3a1b9b35afe6d925da7ee61 (diff)
downloadmeta-openembedded-9656d77b3996acf47973cd7bd91879b409d77a45.tar.gz
nvmetcli: Add initial version 0.7
Add recipe for NVM-Express target user space configuration utility. It contains a command line interface to the NVMe over Fabrics nvmet in the Linux kernel. It allows configuring the nvmet interactively as well as saving/restoring the configuration to/from a json file. Signed-off-by: Jonathan Richardson <jonathan.richardson@broadcom.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/nvmetcli/nvmetcli_0.7.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nvmetcli/nvmetcli_0.7.bb b/meta-networking/recipes-support/nvmetcli/nvmetcli_0.7.bb
new file mode 100644
index 0000000000..31f55e3589
--- /dev/null
+++ b/meta-networking/recipes-support/nvmetcli/nvmetcli_0.7.bb
@@ -0,0 +1,39 @@
+SUMMARY = "NVM-Express target user space configuration utility."
+DESCRIPTION = "This package contains the command line interface to the NVMe \
+over Fabrics nvmet in the Linux kernel. It allows configuring the nvmet \
+interactively as well as saving / restoring the configuration to / from a json \
+file."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+inherit systemd setuptools3
+
+# nvmet service will start and stop the NVMe Target configuration on boot and
+# shutdown from a saved NVMe Target configuration in the /etc/nvmet/config.json
+# file. This file is not installed by default since the configuration will vary
+# on real systems. Example configuration files are provided by including the
+# nvmetcli-examples package.
+SYSTEMD_SERVICE_${PN} = "nvmet.service"
+
+SYSTEMD_AUTO_ENABLE ?= "disable"
+
+RDEPENDS_${PN} += "python3 python3-six python3-pyparsing python3-configshell-fb"
+
+SRCREV = "0a6b088db2dc2e5de11e6f23f1e890e4b54fee64"
+SRC_URI = "git://git.infradead.org/users/hch/nvmetcli.git;branch=master"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ # Install example configuration scripts.
+ install -d ${D}${datadir}/nvmet
+ cp -fr ${S}/examples ${D}${datadir}/nvmet/
+
+ # Install systemd service file.
+ install -d ${D}${systemd_unitdir}/system
+ cp -fr ${S}/nvmet.service ${D}${systemd_unitdir}/system
+}
+
+# Examples package contains example json files used to configure nvmet.
+PACKAGES += "${PN}-examples"
+FILES_${PN}-examples = "${datadir}/nvmet/examples/*"