aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2022-07-07 14:08:58 +0800
committerKhem Raj <raj.khem@gmail.com>2022-07-07 10:26:37 -0400
commite0e1eb4bedc06c6433aa5adef32b41765a698ada (patch)
tree32687b42a81cc47d8ac022e7f20140ffaabdf8ec /meta-networking/recipes-support
parentc098cf9190413f237dc49d29c57be2f579fd4c40 (diff)
downloadmeta-openembedded-e0e1eb4bedc06c6433aa5adef32b41765a698ada.tar.gz
openvpn: add PACKAGECONFIG for selinux
This is useful for selinux distro feature. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb b/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb
index 7404e6e587..1395a35f54 100644
--- a/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb
+++ b/meta-networking/recipes-support/openvpn/openvpn_2.5.7.bb
@@ -37,9 +37,11 @@ EXTRA_OECONF += "SYSTEMD_UNIT_DIR=${systemd_system_unitdir} \
"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)} \
"
PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
+PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
do_install:append() {
install -d ${D}/${sysconfdir}/init.d