aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-10-21 09:20:27 -0700
committerArmin Kuster <akuster808@gmail.com>2021-01-25 21:00:59 -0800
commitf371ec5c245224730cbbfe6ce29d6bedfa3e530d (patch)
tree5bcf863f97061c4f2274b964eb38fa87cb6cb978 /meta-networking
parent0a81e46a209d8ec559a7b2576dac5c56b35aa15d (diff)
downloadmeta-openembedded-f371ec5c245224730cbbfe6ce29d6bedfa3e530d.tar.gz
iscsi-initiator-utils: Silence a clang warning on 64bit systems
This unbreaks the build with clang as well. Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 409032dcc59bed5051cca454f7344b3cd207cebf) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch48
-rw-r--r--meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb1
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch b/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch
new file mode 100644
index 0000000000..c71f01299b
--- /dev/null
+++ b/meta-networking/recipes-daemons/iscsi-initiator-utils/files/0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch
@@ -0,0 +1,48 @@
+From 7bdaa32c80bb7d37668c1ff6d88bb02428459a0f Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 21 Oct 2020 09:11:20 -0700
+Subject: [PATCH] libopeniscsiusr: Compare with max int instead of max long
+
+This compares value member of int_list_tbl struct which is of unsigned
+int type.
+
+struct int_list_tbl {
+const char *name;
+unsigned int value;
+};
+
+Clang compiler reports this comparison when
+-Wtautological-constant-out-of-range-compare is enabled
+
+| idbm.c:1042:2: error: result of comparison of constant 18446744073709551615 with expression of type 'unsigned int' is always true [-Werror,-Wtautological-constant-out-of-range-compare]
+| _rec_int_list(SESSION_CHAP_ALGS, recs, node, session.auth.chap_algs,
+| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+| idbm.c:263:23: note: expanded from macro '_rec_int_list'
+| if (_org->_name[_i] != ~0UL) { \
+| ~~~~~~~~~~~~~~~ ^ ~~~~
+
+Since max value for int can be less than unsinged long e.g. on LP64 its
+better to use UINT_MAX here
+
+Upstream-Status: Submitted [https://github.com/open-iscsi/open-iscsi/pull/227]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ libopeniscsiusr/idbm.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libopeniscsiusr/idbm.c b/libopeniscsiusr/idbm.c
+index 7bc2381..060196f 100644
+--- a/libopeniscsiusr/idbm.c
++++ b/libopeniscsiusr/idbm.c
+@@ -260,7 +260,7 @@ do {\
+ _recs[_n].type = TYPE_INT_LIST; \
+ _strncpy(_recs[_n].name, _key, NAME_MAXVAL); \
+ for (unsigned int _i = 0; _i < ARRAY_LEN(_org->_name); _i++) { \
+- if (_org->_name[_i] != ~0UL) { \
++ if (_org->_name[_i] != UINT_MAX) { \
+ for (unsigned int _j = 0; _j < ARRAY_LEN(_tbl); _j++) { \
+ if (_tbl[_j].value == _org->_name[_i]) { \
+ strcat(_recs[_n].value, _tbl[_j].name); \
+--
+2.29.0
+
diff --git a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb
index 254362881b..dfcd4ee3cb 100644
--- a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb
+++ b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.1.2.bb
@@ -16,6 +16,7 @@ SRCREV ?= "802688debcd88c48edabe86deb7e7ed47ebadc26"
SRC_URI = "git://github.com/open-iscsi/open-iscsi \
file://0001-Makefile-Do-not-set-Werror.patch \
+ file://0001-libopeniscsiusr-Compare-with-max-int-instead-of-max-.patch \
file://initd.debian \
file://99_iscsi-initiator-utils \
file://iscsi-initiator \