aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorLi Zhou <li.zhou@windriver.com>2018-03-01 14:36:02 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2018-04-06 08:12:21 -0400
commit7166aaaf38ebf15d887576050084b92bebef982d (patch)
treeba9e3eda37ee2acba130528e0b00c4161703b331 /meta-networking
parentad8e710be76e193165c6a23c2134ef5a7ea01b09 (diff)
downloadmeta-openembedded-7166aaaf38ebf15d887576050084b92bebef982d.tar.gz
ebtables: enable KERNEL_64_USERSPACE_32 for arm
On arm64 board, run the kernel as 64bit with 32bit userpace ebtables, then run ebtables command: ebtables -A OUTPUT -p arp -o eth3 -j DROP Below error occurs: kernel msg: ebtables bug: please report to author: Standard target size too big To solve this, enable KERNEL_64_USERSPACE_32 for arm as the commit <ebtables: enable KERNEL_64_USERSPACE_32 for powerpc> do. Use TARGET_ARCH to replace KARCH here because that KARCH can't always get value by default. Signed-off-by: Li Zhou <li.zhou@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
index d5e7341a01..d89ee1a206 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
@@ -42,10 +42,10 @@ inherit update-rc.d systemd
python __anonymous () {
import re
- karch = d.getVar('KARCH')
+ karch = d.getVar('TARGET_ARCH')
multilib = d.getVar('MLPREFIX')
- if multilib and karch == 'powerpc64':
+ if multilib and ( karch == 'powerpc64' or karch == 'arm' ):
searchstr = "lib.?32"
reg = re.compile(searchstr)
if reg.search(multilib):