aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorGeoff Parker <geoffrey.parker@arthrex.com>2021-06-17 14:11:18 -0700
committerArmin Kuster <akuster808@gmail.com>2021-06-27 07:37:21 -0700
commita83c773ddd3d3e36d17a560103531657f915f6fe (patch)
treeb0b16b7c08d2aacbaa3d170d49eec27cb2007c1c /meta-networking
parent22f613b047acbe5051e5fad3bba54cecb70a55a0 (diff)
downloadmeta-openembedded-a83c773ddd3d3e36d17a560103531657f915f6fe.tar.gz
cifs-utils: set ROOTSBINDIR to /usr/sbin if DISTRO_FEATURES has usrmerge
Fixes cif-utils recipe build when DISTRO_FEATURES includes 'usrmerge' Add do_configure_prepend() to override ROOTSSBINDIR environment variable so that the utilities are installed in /usr/sbin rather than /sbin. Setting --exec-prefix or --prefix in EXTRA_OECONF does not work. Update do_install_append() to NOT remove /usr/bin /usr/sbin if usrmerge is set in DISTRO_FEATURES Signed-off-by: Geoff Parker <geoffrey.parker@arthrex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 3c1e72d62ccf2c2f94bf280a2500e23fdb01a57c) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/cifs/cifs-utils_6.13.bb17
1 files changed, 14 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/cifs/cifs-utils_6.13.bb b/meta-networking/recipes-support/cifs/cifs-utils_6.13.bb
index 41a9b8e76a..bf8b18043a 100644
--- a/meta-networking/recipes-support/cifs/cifs-utils_6.13.bb
+++ b/meta-networking/recipes-support/cifs/cifs-utils_6.13.bb
@@ -22,10 +22,21 @@ PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disab
inherit autotools pkgconfig
+do_configure_prepend() {
+ # want installed to /usr/sbin rather than /sbin to be DISTRO_FEATURES usrmerge compliant
+ # must override ROOTSBINDIR (default '/sbin'),
+ # setting --exec-prefix or --prefix in EXTRA_OECONF does not work
+ if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','fakse',d)}; then
+ export ROOTSBINDIR=${sbindir}
+ fi
+}
+
do_install_append() {
- # Remove empty /usr/bin and /usr/sbin directories since the mount helper
- # is installed to /sbin
- rmdir --ignore-fail-on-non-empty ${D}${bindir} ${D}${sbindir}
+ if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','false','true',d)}; then
+ # Remove empty /usr/bin and /usr/sbin directories since the mount helper
+ # is installed to /sbin
+ rmdir --ignore-fail-on-non-empty ${D}${bindir} ${D}${sbindir}
+ fi
}
FILES_${PN} += "${base_libdir}/security"