aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/conf
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2020-03-11 16:42:05 +0800
committerKhem Raj <raj.khem@gmail.com>2020-03-11 08:58:57 -0700
commitd178745cbf5c97b7cdcf274108a58c8e1f88d3ca (patch)
treeab1cf2f60e724eeecbfbf4a6c1973c4b5fee2c65 /meta-oe/conf
parentf5d2bf55a8169a9446c2f96f327b3e5d91a6e6cc (diff)
downloadmeta-openembedded-d178745cbf5c97b7cdcf274108a58c8e1f88d3ca.tar.gz
conf/layer.conf: add BBFILES_DYNAMIC and dynamic layers
some recipes under meta-oe have dependency on meta-python, and test_world of yocto-check-layer will failed with error like: ERROR: test_world (common.CommonCheckLayer) ERROR: Nothing PROVIDES 'python3-pytoml-native' (but /meta-openembedded/meta-oe/recipes-extended/mozjs/mozjs_60.9.0.bb DEPENDS on or otherwise requires it). Close matches: python3-numpy-native python3-pycairo-native python3-rpm-native ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'mozjs', 'python3-pytoml-native'] fix by make these recipes only active when identified layers are present Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/conf')
-rw-r--r--meta-oe/conf/layer.conf5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf
index c5377362e7..652a378f28 100644
--- a/meta-oe/conf/layer.conf
+++ b/meta-oe/conf/layer.conf
@@ -23,6 +23,11 @@ BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_openembedded-layer = "6"
+# only activates content when identified layers are present,
+# to ensure yocto compatibility check pass
+BBFILES_DYNAMIC += "meta-python:${LAYERDIR}/dynamic-layers/meta-python/recipes-*/*/*.bb \
+"
+
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_openembedded-layer = "1"