aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/conf
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-17 21:41:22 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-17 21:41:22 +0100
commitc58cc7d3796dcee6e93885c835ed04cb566abeb2 (patch)
tree3eea4d4ef6a4ef79e0f4e025d7012c1a5cc38835 /meta-oe/conf
parenteec6ab97f712e06eb52c9f7c99e19ffab3ce9d74 (diff)
downloadmeta-openembedded-c58cc7d3796dcee6e93885c835ed04cb566abeb2.tar.gz
move layer into meta-oe in preparation for future splits
As per TSC decision Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/conf')
-rw-r--r--meta-oe/conf/layer.conf9
-rw-r--r--meta-oe/conf/machine/include/davinci.inc25
-rw-r--r--meta-oe/conf/machine/include/omap3.inc15
-rw-r--r--meta-oe/conf/machine/include/omapl138.inc1
-rw-r--r--meta-oe/conf/machine/include/tune-arm926ejs.inc7
-rw-r--r--meta-oe/conf/machine/include/tune-cortexa8.inc17
6 files changed, 74 insertions, 0 deletions
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf
new file mode 100644
index 0000000000..9fa60c1c49
--- /dev/null
+++ b/meta-oe/conf/layer.conf
@@ -0,0 +1,9 @@
+# We have a conf and classes directory, prepend to BBPATH to prefer our versions
+BBPATH := "${LAYERDIR}:${BBPATH}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "openembedded-layer"
+BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/"
+BBFILE_PRIORITY_openembedded-layer = "6"
diff --git a/meta-oe/conf/machine/include/davinci.inc b/meta-oe/conf/machine/include/davinci.inc
new file mode 100644
index 0000000000..3e48097eb3
--- /dev/null
+++ b/meta-oe/conf/machine/include/davinci.inc
@@ -0,0 +1,25 @@
+require conf/machine/include/tune-arm926ejs.inc
+
+# Increase this everytime you change something in the kernel
+MACHINE_KERNEL_PR = "r50"
+
+TARGET_ARCH = "arm"
+
+KERNEL_IMAGETYPE = "uImage"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-davinci"
+
+PREFERRED_PROVIDER_virtual/bootloader = "u-boot"
+UBOOT_MACHINE = "davinci_dvevm_config"
+
+UBOOT_ENTRYPOINT = "0x80008000"
+UBOOT_LOADADDRESS = "0x80008000"
+
+EXTRA_IMAGEDEPENDS += "u-boot"
+
+SERIAL_CONSOLE ?= "115200 ttyS0"
+EXTRA_IMAGECMD_jffs2 = "--pad --little-endian --eraseblock=0x20000 -n"
+
+#ROOT_FLASH_SIZE = "29"
+
+MACHINE_FEATURES = "kernel26 serial ethernet usbhost usbgadget mmc alsa"
diff --git a/meta-oe/conf/machine/include/omap3.inc b/meta-oe/conf/machine/include/omap3.inc
new file mode 100644
index 0000000000..15e34c6508
--- /dev/null
+++ b/meta-oe/conf/machine/include/omap3.inc
@@ -0,0 +1,15 @@
+SOC_FAMILY = "omap3"
+TARGET_ARCH = "arm"
+
+require conf/machine/include/tune-cortexa8.inc
+PREFERRED_PROVIDER_virtual/kernel = "linux-omap"
+# Increase this everytime you change something in the kernel
+MACHINE_KERNEL_PR = "r99"
+
+KERNEL_IMAGETYPE = "uImage"
+
+UBOOT_ENTRYPOINT = "0x80008000"
+UBOOT_LOADADDRESS = "0x80008000"
+
+EXTRA_IMAGEDEPENDS += "u-boot x-load"
+
diff --git a/meta-oe/conf/machine/include/omapl138.inc b/meta-oe/conf/machine/include/omapl138.inc
new file mode 100644
index 0000000000..4c222753df
--- /dev/null
+++ b/meta-oe/conf/machine/include/omapl138.inc
@@ -0,0 +1 @@
+SOC_FAMILY = "omapl138"
diff --git a/meta-oe/conf/machine/include/tune-arm926ejs.inc b/meta-oe/conf/machine/include/tune-arm926ejs.inc
new file mode 100644
index 0000000000..f41e460999
--- /dev/null
+++ b/meta-oe/conf/machine/include/tune-arm926ejs.inc
@@ -0,0 +1,7 @@
+FEED_ARCH = "armv5te"
+PACKAGE_EXTRA_ARCHS += "armv4 armv4t armv5te"
+# For gcc 3.x you need:
+#TARGET_CC_ARCH = "-march=armv5te -mtune=arm926ejs"
+# For gcc 4.x you need:
+TARGET_CC_ARCH = "-march=armv5te -mtune=arm926ej-s"
+BASE_PACKAGE_ARCH = "armv5te"
diff --git a/meta-oe/conf/machine/include/tune-cortexa8.inc b/meta-oe/conf/machine/include/tune-cortexa8.inc
new file mode 100644
index 0000000000..2ac0ebfe45
--- /dev/null
+++ b/meta-oe/conf/machine/include/tune-cortexa8.inc
@@ -0,0 +1,17 @@
+# Instead of using -mfpu=vfp[2] we can use -mfpu=neon to make use of gcc intrinsics[1] and vectorize loops with -ftree-vectorize[3]
+# [1] http://gcc.gnu.org/onlinedocs/gcc/ARM-NEON-Intrinsics.html
+# [2] http://gcc.gnu.org/onlinedocs/gcc/ARM-Options.html
+# [3] https://support.codesourcery.com/GNUToolchain/kbentry29
+
+# Can be 'softfp' or 'hardfp'
+ARM_FP_MODE ?= "softfp"
+
+ARM_FP_OPT = "${@['-mfloat-abi=softfp', '-mfloat-abi=hard'][bb.data.getVar('ARM_FP_MODE', d, 1) == 'hardfp']}"
+ARM_FP_PACKAGESUFFIX = "${@['', '-hardfp'][bb.data.getVar('ARM_FP_MODE', d, 1) == 'hardfp']}"
+
+TARGET_CC_ARCH = "-march=armv7-a -mtune=cortex-a8 -mfpu=neon ${ARM_FP_OPT}"
+
+FEED_ARCH = "armv7a${ARM_FP_PACKAGESUFFIX}"
+BASE_PACKAGE_ARCH = "armv7a${ARM_FP_PACKAGESUFFIX}"
+
+PACKAGE_EXTRA_ARCHS += "armv4 armv4t armv5te armv6 armv7 armv7a${ARM_FP_PACKAGESUFFIX}"