aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/fio/fio_2.2.6.bb
diff options
context:
space:
mode:
authorRaphael Silva <rapphil@gmail.com>2015-02-28 20:15:16 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-03 08:36:01 +0100
commit9b35e07cabaf3ed9bd681423a758b9c0dc3945af (patch)
treeb82a302c0bf38c4eda2ab37984d8ca796f60f0f0 /meta-oe/recipes-benchmark/fio/fio_2.2.6.bb
parent7fe80db1df7a43e57cd7807052fbefdcbdbceb5d (diff)
downloadmeta-openembedded-9b35e07cabaf3ed9bd681423a758b9c0dc3945af.tar.gz
fio: fix do_compile error
* Update to v2.2.6 Signed-off-by: Raphael Silva <raphael.philipe@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/fio/fio_2.2.6.bb')
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_2.2.6.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_2.2.6.bb b/meta-oe/recipes-benchmark/fio/fio_2.2.6.bb
new file mode 100644
index 0000000000..016b1f21ad
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/fio_2.2.6.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Filesystem and hardware benchmark and stress tool"
+DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
+stress/hardware verification. It has support for a number of I/O engines, \
+I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
+and much more. It can work on block devices as well as files. fio accepts \
+job descriptions in a simple-to-understand text format. Several example job \
+files are included. fio displays all sorts of I/O performance information."
+HOMEPAGE = "http://freecode.com/projects/fio"
+SECTION = "console/tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
+
+DEPENDS = "libaio"
+
+# rev for v2.2.6
+SRCREV = "f52c9691bc8c285f3445235c69acdfd6de7f9b82"
+SRC_URI = "git://git.kernel.dk/fio.git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
+
+do_install() {
+ oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
+ install -d ${D}/${docdir}/${PN}
+ cp -a ${S}/examples ${D}/${docdir}/${PN}/
+}