aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/fio
diff options
context:
space:
mode:
authorTom Rini <trini@ti.com>2012-03-08 19:49:29 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-09 07:51:15 +0100
commit6b8c314002887600613fde277dc9dfd2b2026ed6 (patch)
treef6b1e36d3fd4c48a87295d1bc91c95e4a6745ec3 /meta-oe/recipes-benchmark/fio
parent629d9fa0675a7f15ee9efad86099e77461bdc2a9 (diff)
downloadmeta-openembedded-6b8c314002887600613fde277dc9dfd2b2026ed6.tar.gz
fio: Add initial recipe for version 2.0.5
Signed-off-by: Tom Rini <trini@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark/fio')
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_2.0.5.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb b/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
new file mode 100644
index 0000000000..4c086c805f
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/fio_2.0.5.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Filesystem and hardware benchmark and stress tool"
+DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
+stress/hardware verification. It has support for a number of I/O engines, \
+I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
+and much more. It can work on block devices as well as files. fio accepts \
+job descriptions in a simple-to-understand text format. Several example job \
+files are included. fio displays all sorts of I/O performance information."
+HOMEPAGE = "http://freecode.com/projects/fio"
+SECTION = "console/tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
+
+DEPENDS = "libaio"
+
+# rev for v2.0.5
+SRCREV = "02efadeb8b05144bcf2fc7796e1da2e7db211d00"
+SRC_URI = "git://git.kernel.dk/fio.git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LDFLAGS='${LDFLAGS}'"
+
+do_install() {
+ oe_runmake install DESTDIR=${D} bindir=${bindir} mandir=${mandir}
+ install -d ${D}/${docdir}/${PN}
+ cp -a ${S}/examples ${D}/${docdir}/${PN}/
+}