aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/libhugetlbfs/files
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-10-12 09:19:53 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-15 13:43:53 +0200
commitf8903f53db717294d63a8d79b5ef7ca34b3c189e (patch)
tree1ac9a0effdb7e9138c5f4320b24348fc514a83f8 /meta-oe/recipes-benchmark/libhugetlbfs/files
parent0e2a691f78669e27a44c03b8a79bd0d0b2dfed0a (diff)
downloadmeta-openembedded-f8903f53db717294d63a8d79b5ef7ca34b3c189e.tar.gz
libhugetlbfs: install perl lib to directory perl instead of perl5
*libhugetlbfs depends on perl, and perl installs a directory 'perl' and make a symlink 'perl5' to it. So just install perl libs in libhugetlbfs to directory 'perl' instead of 'perl5'. This can avoid the following error: | CalledProcessError: Command 'tar -cf - -C .../perl/5.14.3-r1/sysroot-destdir | -ps . | tar -xf - -C .../tmp/sysroots/t4240qds' | returned non-zero exit status 2 with output | tar: ./usr/lib/perl5: Cannot create symlink to `perl': File exists | tar: Exiting with failure status due to previous errors Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/libhugetlbfs/files')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch
new file mode 100644
index 0000000000..0b8d0e4d54
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-install-perl-lib-to-directory-perl-instead-of-perl5.patch
@@ -0,0 +1,39 @@
+Upstream-Status: Inappropriate [oe-core specific]
+
+libhugetlbfs depends on perl, and perl installs a directory 'perl'
+and make a symlink 'perl5' to it. So just install perl libs in
+libhugetlbfs to directory 'perl' instead of 'perl5'. This can avoid
+the following error:
+| CalledProcessError: Command 'tar -cf - -C .../perl/5.14.3-r1/sysroot-destdir
+| -ps . | tar -xf - -C .../tmp/sysroots/t4240qds'
+| returned non-zero exit status 2 with output
+| tar: ./usr/lib/perl5: Cannot create symlink to `perl': File exists
+| tar: Exiting with failure status due to previous errors
+
+
+Signed-off-by: Ting Liu <b28495@freescale.com>
+
+--- a/Makefileold 2013-10-11 23:07:31.759421318 -0500
++++ b/Makefile 2013-10-11 23:08:01.935571122 -0500
+@@ -173,17 +173,17 @@
+ DOCDIR = $(PREFIX)/share/doc/libhugetlbfs
+
+ ifdef CC32
+-PMDIR = $(PREFIX)/lib/perl5/TLBC
++PMDIR = $(PREFIX)/lib/perl/TLBC
+ endif
+
+ ifdef CC64
+ ifeq ($(ARCH),x86_64)
+-PMDIR = $(PREFIX)/lib/perl5/TLBC
++PMDIR = $(PREFIX)/lib/perl/TLBC
+ else
+ ifeq ($(ARCH),aarch64)
+-PMDIR = $(PREFIX)/lib/perl5/TLBC
++PMDIR = $(PREFIX)/lib/perl/TLBC
+ else
+-PMDIR = $(PREFIX)/lib64/perl5/TLBC
++PMDIR = $(PREFIX)/lib64/perl/TLBC
+ endif
+ endif
+ endif